#1
Hello - I am new to the forum. I have a what I believe is a 2004 Fender super reverb amplifier. The issue I am having is when I turn on the amp there is a loud hissing noise (very annoying), and the amp makes a popping noise quite often. I believe it may be the old original tubes. Any advice on a fix?

Thanks!
#3
Power tubes.

You could give the pre's the pencil test, but I doubt you'll find much; all signs point to a re-tube, Fender shipped those with (IMHO) so-so tubes...
#4
In addition to the tubes, there's apparently some kind of pot that can be adjusted with a screwdriver which adjusts the amount of noise coming from the tubes.
#5
Quote by imicius
In addition to the tubes, there's apparently some kind of pot that can be adjusted with a screwdriver which adjusts the amount of noise coming from the tubes.


The bias pot?! No touchy!!!

That's the only screw pot on a SR I can think of, AFAIK the RI's do not have a "hum" pot, I know the originals did not...

At any rate, do NOT adjust this unless you are fully familiar with amp biasing.
#6
listen to the man that is the Rutch... he's from Chicago and carries an AK-47 in a viola case.
I wondered why the frisbee was getting bigger, then it hit me.
#7


It's true.

I shoot those who abuse animals, children and Fenders, and not necessarily in that order...
#8
Quote by Rutch
The bias pot?! No touchy!!!

That's the only screw pot on a SR I can think of, AFAIK the RI's do not have a "hum" pot, I know the originals did not...

At any rate, do NOT adjust this unless you are fully familiar with amp biasing.

Yeah, the hum pot. It's on the TRRI, don't know about the Super Reverb.