#1
Right:
I recently bought a second hand TC Electronic Gmajor. It works fine, but when I put it into the effects loop of my ENGL Fireball, it gives a huge rustling noise. The noise goes louder when I turn up the volume. Having the Gmajor turned off (as in on, but no effects active) still gives a rustling noise.

I tried just running a cable through the FX Loop; when I do that, I get no noise.
I tried running the Gmajor through the FX Loop on my MG, didn't get noise.
I tried the Gmajor in front of the pre-amp, even more noise than in the FX Loop.

Please help, I don;t know what to do and I don;t know whether my Fireball or my recently acquired second-hand Gmajor is damaged.
Help is very, very much appreciated.
I do not want to have a signature anymore.
#3
Anyone, please?
I do not want to have a signature anymore.
Last edited by RDSElite at Dec 14, 2009,
#4
Find out which of your preamp tubes drive your F/X loop, it may be bad. Assuming ENGL's have a tube driven F/X loop. If you have some known good preamp tubes swap them out and see what happens.
If you start a reply with: I have never played one but I have heard good things about it! Your opinion is invalid.
#5
So I have to check into getting new tubes?
I'm desperate, it just needs to work properly.
Please help.
I do not want to have a signature anymore.
#6
Probably just one 12ax7 If that is the problem.

Also do you know if your F/X loop is parallel or serial. This could also be a problem. If it's parallel. You may not have 100% wet signal going through the G-major.


Do you have a fireball 60 or 100?
If you start a reply with: I have never played one but I have heard good things about it! Your opinion is invalid.
Last edited by boxcarmonument at Dec 15, 2009,
#7
You can switch it between Serial and Parallel, with a know on the back that goes from Wet to Dry. You can change this on the Gmajor as well, but it doesn't fix the problem..

I have a Fireball 60
I do not want to have a signature anymore.