#1
I have a Peavey Valveking 112 amp. I boost it with a TS9DX and this Christmas, I got an MXR 10 band EQ. I was stoked to use it, so I threw it in my FX loop and dialed in a metal setting.

When I turned it on, I noticed my distortion turned suddenly very fizzy. The gain on my Line 6 Spider III's Insane channel sounds better. So then I started messing with it, trying to isolate the frequency of the annoying fizz. I found that the 4K and 8K sliders, mainly the 8K sliders were where the fizz was. However, I can't just turn it down, because I lose all my high end sound, which is crucial to me. I know it is the amp, because I ran a distortion pedal through the clean channel and still got the buzz.

Now it's actually becoming apparent to me, even without using the EQ. The fizz is just quieter, but its still there.

Does anyone else have this problem? I'm thinking about calling Peavey and asking them about this, because if this problem doesn't go away I'm going to get rid of it. The sound is just complete shit.
Ibanez RGT42DX
Vox AC30C2
Digitech Whammy (FOR SALE!)
Dunlop GCB-95F Crybaby
Boss DD-20
Boss SD-1
Ibanez TS9DX
MXR M-108 10 Band EQ
#2
have you tried replacing the tubes? thats the first thing to do when a tube amp acts up. what you describe sounds like a bad tube or two for sure.
#3
Nope, but I don't know if that'd do anything. This is like, the distortion just sounds fizzy and nasty.

I have not replaced the tubes, I suppose I could order a few new tubes. I've only had the amp since mid August though, and I only use it maybe twice a week.
Ibanez RGT42DX
Vox AC30C2
Digitech Whammy (FOR SALE!)
Dunlop GCB-95F Crybaby
Boss DD-20
Boss SD-1
Ibanez TS9DX
MXR M-108 10 Band EQ
Last edited by soul.power at Dec 27, 2009,
#4
With an EQ, you can't just dial in a 'metal' setting (I assume you're just scooping mids with the pedal). You've got to mess with it. Mine ended up vaguely like a sineoid curve.
Quote by DeathByDestroyr
What the hell is a G&L.



Quote by Flux'D
Gay & Lesbian I think, the box smelled funny
Greg what did you send me??
#5
The VK has some natural fizz (that goes away after an OT change) but it usually isn't too overbearing.

If the problem seems to be getting worse, it is probably the preamp tubes. It shouldn't cost too much to replace them.

Be sure you are using the power supply with the EQ.
Experiment a bit more with settings and you may find something that sounds good to you... the settings in the wiki are more or less guidelines for you to base your sound off of.
#6
Quote by Raijouta
With an EQ, you can't just dial in a 'metal' setting (I assume you're just scooping mids with the pedal). You've got to mess with it. Mine ended up vaguely like a sineoid curve.


I did, and mine also does look like slightly like a sine wave. The problem is that when the 4K and 8K slider are moved, my distortion gets fizzier and fizzier.

The VK has some natural fizz (that goes away after an OT change) but it usually isn't too overbearing. If the problem seems to be getting worse, it is probably the preamp tubes. It shouldn't cost too much to replace them. Be sure you are using the power supply with the EQ. Experiment a bit more with settings and you may find something that sounds good to you... the settings in the wiki are more or less guidelines for you to base your sound off of.


I'll order some new tubes then. I guess I should look at them and tap them and stuff to see if anything unusual happens as well.

Raijouta, I know you replaced your OT. Do you have a link to where you got yours from? My bandmate's dad is into electronics and could probably replace it for me.

Overall though, I'll try to do some experimenting and maybe post a soundclip
Ibanez RGT42DX
Vox AC30C2
Digitech Whammy (FOR SALE!)
Dunlop GCB-95F Crybaby
Boss DD-20
Boss SD-1
Ibanez TS9DX
MXR M-108 10 Band EQ
Last edited by soul.power at Dec 27, 2009,
#7
Uh, google Weber Electronics. I use the Weber OT45HHR (I think that's what it's called).
Quote by DeathByDestroyr
What the hell is a G&L.



Quote by Flux'D
Gay & Lesbian I think, the box smelled funny
Greg what did you send me??