#1
So, I got a Crybaby From Hell wah pedal last Wednesday, the 23rd. I loved it and no trouble with it. However, a couple hours ago, after having stopped playing my guitar a while ago, I plugged in my distortion pedal and the CFH and went to step on the pedal and got nothing. I looked at the LED on the back and saw that is wasn't on. I thought maybe the battery died, so I replaced it (twice, just to be sure) and nothing happened. I read through the owner's manual and found nothing other than it telling me to use a 9V battery if the product wasn't turning on, if that isn't the most obvious thing ever. Can anybody explain this? It was working fine a few hours ago. The kick boost switch on the side will turn on...at least the LED in the back will. I turn everything on and hit the boost and the red light comes on, but the boost does not activate in the tone of my guitar. Is this a sign that the pedal is still working or is it toast?
#2
Try getting a power supply.
Batteries can sometimes mess with things a bit.
My gear so far:

-Cort KX5 (pearl white)
-Crybaby Wah
-Danelectro Cool Cat
-Fender Twin Reverb 65' Reissue
-Hardwire TL2
#3
Quote by Rockerdude22
Try getting a power supply.
Batteries can sometimes mess with things a bit.


But, that wouldn't make sense. Why would the battery cause it to suddenly stop working? It worked fine for 4 days straight. I only replaced it after it didn't turn on.

EDIT: Well, it doesn't matter. I'm having it replaced anyway.
Last edited by Inferno_WRXT at Dec 28, 2009,