#1
Hello. I have recently bought a digitech metal master off of eBay, Im not sure if that voids the warranty or not. But it's acting strange but some times when I put my cords the pedal an start her up she plays fine, but most of the time I get a choppy helicopter like sound, and other times the pedal won't even come on. This disapponts me, I have had the pedal for about a week and fell in love with it and now It breaks, those f you familiar with the digitech pedals know they have the warranty sticker on the back, I have this but no receipt can I send it in for a new one?, or could someone tell me what's wrong with it?I have tried various batteries and power boxes. Thanks ug.
Quote by herby190
When I saw that, I thought of musical notes.... my elementary school teachers taught them as "tee-tees" "ta-tas" and a bunch of other nonsense....
#3
Fender automatic se 25 watt solidstate. I've had other digitech pedals that work just fine with the amp badmonkey, grunge ect.
Quote by herby190
When I saw that, I thought of musical notes.... my elementary school teachers taught them as "tee-tees" "ta-tas" and a bunch of other nonsense....
#4
Did the problem start before you tried various AC adapters ("power boxes")?

Does the LED stay on when your cables from the guitar and to the amp are connected?
If it is flickering, then there may be an intermittent or loose battery or ac adapter connection. GENTLY wiggle each cable to see if that changes anything.
#5
are you leaving the battery in while plugged in? ive had this issue with digitech before otherwise it may be a loose connection to the mboard
my gear//
GUITARS
ESP Horizon Custom
ESP M202BB
ESP HB300
Gibson LP Custom
Gibson V
AMPS
Orange Rockverb 50
Mesa Triple Recti
Marshall JCM800 2210
#6
if you dont have a copy of the receipt your screwed. I sent my pedal in to digitech and they took care of everything in a good manner.