#1
I have a Peavey JSX I got in September. Just today it started to make crackling noises whenever it's on. Is this a sign of the tubes dying? If it is, then how do I find out which tube is the broken one? If it isn't, then what do I do about it?

Btw, I did check to make sure it was the amp and not the cable or my guitar.
Last edited by __Pent__ at May 27, 2010,
#2
FX loop?

http://drzamplifiers.proboards.com/index.cgi?board=maz18&action=display&thread=31154
Posted by: bckasik
"Retubed the whole thing and it didn't help...

I tried different guitars with different cords...

Checked all the chassis screws and they were fine...

When I wired the pickup for the 4-way switch I isolated the pup cover...

It ended up being the effects loop. I sprayed de-ox-id in the jacks and cleaned them out and the problem was gone.

So anyone out there that get a buzz you can't get rid of, try cleaning the effects loop jacks.

Thanks to everyone for their responses.
".
Last edited by BurstBucker Pro at May 27, 2010,
#3
Quote by BurstBucker Pro
FX loop?

http://drzamplifiers.proboards.com/index.cgi?board=maz18&action=display&thread=31154
Posted by: bckasik
"Retubed the whole thing and it didn't help...

I tried different guitars with different cords...

Checked all the chassis screws and they were fine...

When I wired the pickup for the 4-way switch I isolated the pup cover...

It ended up being the effects loop. I sprayed de-ox-id in the jacks and cleaned them out and the problem was gone.

So anyone out there that get a buzz you can't get rid of, try cleaning the effects loop jacks.

Thanks to everyone for their responses.
".


I'll try that, but would that even be a problem if I keep the FX loop off?