#1
Okay, so, My Electro acoustic is broken.. Sort of.

I gig with this guitar pretty regularly, three/four times a month for the last year. And then yesterday, two days out of warranty (because thats always the way) the guitar starts making this horrible low end buzz, that completely distroys the sound of the guitar. BUT GET THIS. The sound goes away when you touch any part of the circuit that goes to the pickup.

At first i think, oh, must be the cable, not earthing. WRONG.
Then i take out the input, check everything wired Ok. ITS FINE.
I take off the bridge (where the pickup is slotted underneath) and NOTHING CHANGES.

Basically, i've tried everything i can think of.

I work with sound on and off when i need the money, and i know my way around a guitar, but this isn't anything like anything ive come across before.

Im completely stumped. Ive tried it in different amps, different cables, changed the battery in the EQ, adjusted the input to try and stop the pins touching the whole jack (which im now convinced isn't the problem). Pretty much, ive tried everything short of dragging out the circuit board, which I REALLY dont want to have to do..

Any suggestions??
#2
To the acoustic guitar forum with you!

Or the electric one, I dunno what this'd fall under.

And is the buzz from the guitar or the amp? Because if it's from the amp it's more than likely the jack or the wires connecting to it are shorting out.

Now be gone!
...Stapling helium to penguins since 1949.
Last edited by Todd Hart at Jul 7, 2010,
#4
Be Electric Forum this falll under due to pickup problems
Gibson Les Paul Custom (Aged White)
Custom Kramer Baretta
Custom Fender Strat
Epiphone Black Beauty
Epiphone AJ
Marshall JCM900 4201
Blackheart Little Giant
MXR Dist. +
MXR Six Band EQ
MXR Phase 90