#1
i was on the site earlier today, and everything was fine. then i upgraded to a newest version of firefox, updated java, and did latest windows update, and all of a sudden none of the videos on here work...

any ideas which of these could have caused the problem? i'm thinking firefox update may have done it, but i want ideas.

thanks in advance guys!
#2
I use Opera but you should try reinstalling Java
Quote by UntilISleep
You have excellent taste in literature, dear sir

Quote by Primus2112
You have excellent taste in video games, good sir.

Quote by GbAdimDb5m7
You have terrible taste in signatures, idiotic sir.

kkoo
#3
Quote by SlackerBabbath

I also have hairy butt cheeks, I once shaved a letter 'W' on each cheek, so that when I bent over it spelled WoW.

warning, some of the contents of this post may not necessarily be completely true.
#5
Try to uninstall it.
Quote by SlackerBabbath

I also have hairy butt cheeks, I once shaved a letter 'W' on each cheek, so that when I bent over it spelled WoW.

warning, some of the contents of this post may not necessarily be completely true.
#6
really guys? i'm asking for serious suggestions because i wont have much available time for a few days to try and find the problem on my own. its just a little annoying that videos wont play, but its not only this site. some on sympatico's live music thing wont play either as well as aol music...

to the only person who suggested a real thing (reinstalling java), its not all things. just ones that come from certain sites i think. it loads to a certain point, then in the bottom i just see a web domain or site (not sure what it is really) and it doesn't want to load past that so no videos. all other things seem to work (i tried other videos, games, websites).