#1
Hey guys,

I was playing my Bugera 333 212 today, at a low volume, as almost always, and suddenly my sound became a bit softer. I turned around, looking @ my amp like wth is wrong, and all of a sudden, it popped, and all the lights go out, and now I can't turn it on. I already checked the fuse, but it's a solid white one, so i dont know if its blown..

Do you guys have any idea what it was, or what i should do??
inb4 buy a better amp.

thnx in advance!

Jeroen(teh sad guitarist atm)
Quote by ChucklesMginty
Yeah Ibanez and Gibson design all their models on their iPods.

Pokémon CYOA
Click here for my electro tunes!

Proud user and abuser of Bugera
#2
I would say it is a fuse
Quote by element4433
One time I watched a dog lick his own dick for twenty minutes.

Quote by Roc8995
No.


Well, technically it could be done, but only in the same way that you could change a cat into a hamburger. It's an unpleasant process, and nobody is happy with the result.
#3
me 2, but! when the fuse is blown, something must be wrong inside the amp? why else would the fuse blow?
Quote by ChucklesMginty
Yeah Ibanez and Gibson design all their models on their iPods.

Pokémon CYOA
Click here for my electro tunes!

Proud user and abuser of Bugera
#5
okay, thanks!
tomorrow i'm gonna buy a new fuse (god knows where.. do you know any place WtrPlyr?? since you're from holland) and hopefully fix the problem.
Quote by ChucklesMginty
Yeah Ibanez and Gibson design all their models on their iPods.

Pokémon CYOA
Click here for my electro tunes!

Proud user and abuser of Bugera
#6
This happened once with my deluxe reverb, come to find out the reason for the fuse blowing was the power transformer was shot and cost me $300 to get it fixed.
#7
okay, bad news!!! new fuse in, flicked the switch and, B0000M! does that happen with bad tubes or is it worse?
Quote by ChucklesMginty
Yeah Ibanez and Gibson design all their models on their iPods.

Pokémon CYOA
Click here for my electro tunes!

Proud user and abuser of Bugera
#8
Try plugging it into another outlet. If it happens again, your going to have to get it serviced.
#9
okay, ill try (thank god i bought 10 fuses) does anyone have a clue what it could be? it all makes me a sad panda
Quote by ChucklesMginty
Yeah Ibanez and Gibson design all their models on their iPods.

Pokémon CYOA
Click here for my electro tunes!

Proud user and abuser of Bugera
#10
other outlet, same story
Quote by ChucklesMginty
Yeah Ibanez and Gibson design all their models on their iPods.

Pokémon CYOA
Click here for my electro tunes!

Proud user and abuser of Bugera
#11
Quote by SoulSlaughter
other outlet, same story


Are you confident you got the right fuse? Make sure you matched the amps. Also, make sure it's the "Slow Blow" type.
I've also heard that fuses can blow if your power tubes failed or if the amp isn't biased correctly, but I'm not 100% on that. But check your power tubes and see if those are blown.
#12
well, on the amp it says 1.6a fuse 230v, but now that you said it, on the back of the package it says quick acting fuses... so maybe wrong fuses..

on the power tubes, how can i check them that they are blown? i've looked at them yesterday, but they all looked normal, but I'm kinda new to tube amps
Quote by ChucklesMginty
Yeah Ibanez and Gibson design all their models on their iPods.

Pokémon CYOA
Click here for my electro tunes!

Proud user and abuser of Bugera
#13
Take it to a tech, like I said before maybe the transformer maybe not , but since you know nothing about amps then it´s safer if you give it to someone who does.