#1
Alright, I've got a problem with my B-52 AT 112. After about 10 minutes of playing, clean or overdrive channel, it starts to make an odd sound. It sounds kind of crackly, buzzing, and whooshing, almost like it's playing a recording of the wind is blowing. Anyone have any ideas about what could be wrong? I always let it warm up, have never dropped it, and have had it for only 2 years.
#2
Tubes sound microphonic. Time to replace them.

Ensure nothing in your signal chain is doing it but it sounds like the tubes!
Blackstar ID:15TVP
2001 MIA Strat (SD '59/Stock/CustomCustom)
Early 80s Fernandes The Revival '57
#3
I completely unplugged everything except for the power cable, and it still makes the noise. Simple tube problem then I suppose. How do I go about fixing this? Take it to a store? About how much do new tubes cost?
Call me Michael...

Mixing
Need something mixed? Send me a PM with the details! Cheap rates, fast turnaround, satisfaction guaranteed!

Certifications:
Pro Tools HD9
Logic Pro 9 Master Pro
#4
If you're uncomfortable already I would take it to a tech. Preamp tubes can cost about 15 to 20 a pop for nice ones and power tubes are anywhere from 30 a pair and up. All depends on what type brand and quality.

Take it to a tech they can determine if it's tubes or not and go from there. Good luck! Many users here will be more than happy to help you out with specifics if I can't too
Blackstar ID:15TVP
2001 MIA Strat (SD '59/Stock/CustomCustom)
Early 80s Fernandes The Revival '57
#5
Sounds good man. I'll probably take into GC in a few days. Thanks for the help!
Call me Michael...

Mixing
Need something mixed? Send me a PM with the details! Cheap rates, fast turnaround, satisfaction guaranteed!

Certifications:
Pro Tools HD9
Logic Pro 9 Master Pro