#1
so i recently got a marshall haze 40 tube combo for christmas. its been doing great and i love the tone i get with my american standard strat. however a couple weeks ago it started making this clicking sound when i switched channels and now it wont switch channels at all. the footswitch wont work at all and the channel button on the amp doesnt work either. also the effects dont work... anybody have any idea what would cause this? and what i need to do to get it fixed...

P.S. the clean channel works perfectly... just no effects
dave matthews might.. just.. be.. god..

Quote by gregs1020
yes, pointing it at your head will send the sound towards your head.


it's the same with guns too, before you go testing that one.
#2
Quote by uncboy19
so i recently got a marshall haze 40 tube combo for christmas.

Recently, for christmas?
#3
i mean thats pretty relatively recent. i dont usually get a new amp every 6 or 7 months ha
dave matthews might.. just.. be.. god..

Quote by gregs1020
yes, pointing it at your head will send the sound towards your head.


it's the same with guns too, before you go testing that one.
#4
Quote by uncboy19
i mean thats pretty relatively recent. i dont usually get a new amp every 6 or 7 months ha

Ic, sorry for being a douche ^^
#5
is the pedal plugged in all the way?
I wondered why the frisbee was getting bigger, then it hit me.
#6
@jack: nah dude no worries

@gregs1020: yes i have made sure the pedal was plugged in all the way, the jacks are tight and everything. that wouldnt explain it not switching channels on the actual amp though
dave matthews might.. just.. be.. god..

Quote by gregs1020
yes, pointing it at your head will send the sound towards your head.


it's the same with guns too, before you go testing that one.
#7
if it were in half way it may have. i'm at a loss though honestly.
I wondered why the frisbee was getting bigger, then it hit me.
#8
Can you tell if the tubes are ok?

If its not the tubes a clip or something on the inside may have melted. Sounds very similar to a problem Bugera was having with clips melting.

If it is still under warranty I would just take it back.
Gear
Jackson RR24M - EMG ALX w/ ABQ installed
Ibanez Xiphos - stock
LTD Alexi 600 - stock
Ibanex RG - Tone Zone(bridge), PAF Pro(neck)
Blackstar HT-20H
Fulltone OCD
MXR 10 Band EQ
#9
i have no clue. i thought it might be tubes, but wouldnt the clean channel mess up too?
dave matthews might.. just.. be.. god..

Quote by gregs1020
yes, pointing it at your head will send the sound towards your head.


it's the same with guns too, before you go testing that one.
#10
new amp = warranty send it back, just check your signal chain 1st

in fact what is your signal chain

guitar>effect 1>effect 2, etc......>amp

are you using the effects loop or is it just the onboard effects?
#11
Guitar > Crybaby > TS9 > Amp. not using the effects loop. i was told it'd be better not to use the FX loop with a wah and overdrive/boost. and i use the echo on the amp for solos and reggae
dave matthews might.. just.. be.. god..

Quote by gregs1020
yes, pointing it at your head will send the sound towards your head.


it's the same with guns too, before you go testing that one.
#12
if i just take it back to guitar center will they just replace it? or will i get a store credit? id love to hit the jackpot and find a used deville when i walk in lol
dave matthews might.. just.. be.. god..

Quote by gregs1020
yes, pointing it at your head will send the sound towards your head.


it's the same with guns too, before you go testing that one.
#13
If they have more in stock they may just want to replace it, but if you are willing to spend more money on top of the cost of that amp they may let you upgrade.

Tell them this incident put a sour taste in your mouth about the Haze and they should let you get store credit to use towards something else.

Best to call them and find out what will be happening before you drive out to GC.
Gear
Jackson RR24M - EMG ALX w/ ABQ installed
Ibanez Xiphos - stock
LTD Alexi 600 - stock
Ibanex RG - Tone Zone(bridge), PAF Pro(neck)
Blackstar HT-20H
Fulltone OCD
MXR 10 Band EQ
#14
Quote by uncboy19
Guitar > Crybaby > TS9 > Amp. not using the effects loop. i was told it'd be better not to use the FX loop with a wah and overdrive/boost. and i use the echo on the amp for solos and reggae


that`s right you don`t want anything with a gain structure in the loop.

are the pedals actually powering up.

try one pedal at a time.
#15
well i leant it to my neighbor to play a church gig and he's kind of knowledgable about amps and he just told me he fixed it and he's gonna show me what was wrong with it when he drops it back off...
dave matthews might.. just.. be.. god..

Quote by gregs1020
yes, pointing it at your head will send the sound towards your head.


it's the same with guns too, before you go testing that one.
#16
I bet it was a fuse or a tube.

Let us know.....I want to know how our diagnosis' were.
Gear
Jackson RR24M - EMG ALX w/ ABQ installed
Ibanez Xiphos - stock
LTD Alexi 600 - stock
Ibanex RG - Tone Zone(bridge), PAF Pro(neck)
Blackstar HT-20H
Fulltone OCD
MXR 10 Band EQ