#1
Ok, so there is something weird about my DS-1. I've had it for some time, and it distorts only when the distortion knob is greater than 3 o'clock. On YouTube all the videos show that it distorts even at minimal level of distortion. But most of the demos were with tube amps and i use it with a shitty 10watt solid state, is that the problem or is there something wrong with my pedal? (when the dist. knob is around 12 or less it just gives a kind of volume boost but it's still clean-ish)
#2
that does sound somewhat abnormal, the DS-1 should sound fairly gritty with the distortion control turned all the way down.

Are you running off a battery? Have you tried changing it?
I like analogue Solid State amps that make no effort to be "tube-like", and I'm proud of it...

...A little too proud, to be honest.
#4
Quote by rkk94
Ok, so there is something weird about my DS-1. I've had it for some time, and it distorts only when the distortion knob is greater than 3 o'clock. On YouTube all the videos show that it distorts even at minimal level of distortion. But most of the demos were with tube amps and i use it with a shitty 10watt solid state, is that the problem or is there something wrong with my pedal? (when the dist. knob is around 12 or less it just gives a kind of volume boost but it's still clean-ish)


My DS-1 sounds distorted at 1 through my Marshall MG and various tube amps like a Fender Blues Deluxe (I think it was called that? ) that I've used it in. Have you tried messing about with the level and tone knobs?
Fender Jaguar 1994
Gibson Thunderbird

Fender Hot Rod Devile 4x12

Zvex Fuzz Factory
EHX Big Muff
Zvex Box of Rock
Joyo Tremolo
Digitech Whammy
EHX Cathedral
Boss DD3
Boss TU3
#5
yeah ofcourse, maybe i should have it chcked out at the guitar shop or something