#1
Hello, I recieved a virus that made it so that i cannot open .exe files. I tried opening them and then i selected some option to open all .exe files with windows media center. All my icons have the media center logo on them and none of them work. I think that i resolved the virus with avg 9.0 but my programs still try to open with the media center. how do change it back to how it was originally. thank you very much
Quote by Godsmack_IV
Emus. Seriously, no bird should be that big.

Quote by CFH82
Long story short, I had a dream I fu**ed a horse.


Rise up
We are revolutionaries
Viva la revolución
#2
Do whatever you did to set it to media center, but choose the right program instead.
Quote by IRISH_PUNK13
The grandmother is having a baby with her grandson, so the grandson will be his own fathers father, the baby will be his own grandfather, and grandson, and the grandmother will be the mother, and great grandmother?

Quote by TheBurningFish
ಠ_ಠ
#3
Quote by smartalec007
Do whatever you did to set it to media center, but choose the right program instead.

well obviously but idk how i did
Quote by Godsmack_IV
Emus. Seriously, no bird should be that big.

Quote by CFH82
Long story short, I had a dream I fu**ed a horse.


Rise up
We are revolutionaries
Viva la revolución
#6
Computer thread, but what i would do, is format, you need to learn and understand how computers work a bit more or else these things are gonna keep happening to you, i see computers that families use and it's a complete disaster sometimes. xD

By that i mean, I'd go to a friend's house and see the computer that the whole family uses, it's messy, and there's no indication on it that tells me that someone who understands computers ever touched it.
Last edited by ikitson at Aug 21, 2010,
#7
How did you change .exe files to open with Windows Media Center? I just right clicked some .exe files and it doesn't have the "Open With..." option, so I'm not sure what you've done.
Quote by Telestar
Trust me man, it's Smoke on the Water. Deep Purple only wrote one song.
#8
It's funny how people think that as soon as something goes wrong they have a virus. More likely the problem was caused by some noob messing with settings.
PPPPPPPOSTFINDER
#9
Quote by breadstick
It's funny how people think that as soon as something goes wrong they have a virus. More likely the problem was caused by TS messing with settings.

Fixed.
Quote by IRISH_PUNK13
The grandmother is having a baby with her grandson, so the grandson will be his own fathers father, the baby will be his own grandfather, and grandson, and the grandmother will be the mother, and great grandmother?

Quote by TheBurningFish
ಠ_ಠ
#10
System restore should fix your problem, but should probably run Malwarebytes first to make sure virus is gone
Quote by MagicsDevil




29 internets to you, good sir.


Quote by undecided1993
Well I apologise for not taking pictures of my naked mother.


Pokémon SoulSilver Friend code:0775-6767-8676
#11
If the virus in question is 'vistadefender' then its a real bitch to remove. In most cases reformatting your drives is easiest way but you can also try looking here for removal tips

http://www.spywareremove.com/removeVistaDefender.html

If you've already removed it then you probably just need to clean the registry to reset the default run program for .exe (Ccleaner is what i used)
Appreciating Metal since 1998



R.I.P - Ronnie James Dio

1942-2010
#12
Quote by Alive@myfuneral
If the virus in question is 'vistadefender' then its a real bitch to remove. In most cases reformatting your drives is easiest way but you can also try looking here for removal tips

http://www.spywareremove.com/removeVistaDefender.html

If you've already removed it then you probably just need to clean the registry to reset the default run program for .exe (Ccleaner is what i used)

the virus isnt the problem its that i cant run anything
Quote by Godsmack_IV
Emus. Seriously, no bird should be that big.

Quote by CFH82
Long story short, I had a dream I fu**ed a horse.


Rise up
We are revolutionaries
Viva la revolución
#13
Quote by Triviumsucks666
the virus isnt the problem its that i cant run anything



And that probably means that the virus code is still in the registry, corrupting it. Even if the virus isn't active, as long as its code is in the registry it will prevent things with a .exe extension from running. Either attempt to get malwarebytes running or remove the code manually (instructions in that last link)


If the virus is gone then use this to clean your registry and see if that helps
http://www.piriform.com/ccleaner
Appreciating Metal since 1998



R.I.P - Ronnie James Dio

1942-2010