#1
(I tried searching the Toontrack site, the Support Portal + Forum but couldn't find anything. I figured there would be more traffic here, so ...)

Hey, I have Superior Drummer 2.0 and I would want to update it to version 2.2.3 but after trying it like 10 times, it still says 2.2.1. I have downloaded and installed the update from their site several times but it doesn't help.

Anyone else experienced this?

-----
Fixed!
I had to install BOTH the 32 bit and 64 bit versions and now it works! (I have a 64 bit operating system).
Last edited by mpalin at Mar 29, 2011,
#2
I had this issue with EZDrummer. I seriously have no idea how to fix it. I haven't had the issue with Superor Drummer but I don't think I've tried updating it.

but yeah, you must not be the only one with this problem.

re-installing could possibly fix it.
Last edited by TechnicolorType at Mar 28, 2011,