#1
Hey everyone,

Got everything set up with FL Studio 8 and EZ Drummer. My Pod X3 live is in the shop getting the usb dropout issue fixed (warranty) and I want to get set up for drums.

I'd prefer to tap out beats and rhythm myself versus plotting it out on the computer. I have an old Boss DR5 that still works (display is so-so though). Would I be better off using that and exporting the midi (I assume I'd need a midi cable and something to connect it to my computer) or something like an Akai MPD18 and just use it for the pads?

Thanks in advance, I can't wait to start putting stuff together.
Lefties Unite!
#2
In my experience, I've found piano roll to be the easiest way to program drums. I've got a midi controller with pads I tried for a while, which was novel at first, but ended up being a lot less efficient. The only time I use the controller now is for jamming or jazz drums.
#3
I use my Akai MPD24 and like it :/ Its up to you really...to be honest I am lazy and piano roll it half the time....I do like triggering other things with MPD though (especially live)
#4
I just plugged it in, works fine...maybe I'll give it a shot since I already have it and would rather not drop more money if I can just use this. Now I just need to find a hub or whatever to plug it in...so much to do!
Lefties Unite!
#6
Ok I tried using the piano roll, just clicking in each beat and it was hell. I definitely need to "play" the parts like I did on the DR5. I'm going to pick up a cpu-midi interface and hook it up as a controller. I also have an old yamaha keyboard with pads that also is midi capable...I'll see if that one works.

If all else fails I'll get that Akai mini/MPD18 or something like that.
Lefties Unite!
Last edited by ActofGod at Apr 5, 2011,
#7
Ok, I picked up the MPD18 and got it connected to FL Studio/EZ drummer...I just can't figure out how to tap out a pattern.

Can anyone help me? This is ridiculously frustrating.
Lefties Unite!
#8
Connect the MPD18 before opening FL (YOU MUST ALWAYS DO THIS!).

Go to the settings of FL (Press F11). Go to "System". In the Midi area click on "AKAIPROMPD18" (or something like that) and make sure the light beside "Enable" is on. If not select the dark box and it should turn orange. (Once you do this step you should never have to again assuming you even have to do it the first time).

Open EZ Drummer. Make sure you have EZ Drummer selected. Hit the record button. Select "Record Everything". Wait for the 4 count and tap away. If you like that pattern then select pattern 2 and record again.

If you are having problems with the MPD18 connecting to your computer (for example: windows cannot install drivers) let me know Akai sent me a fix for that on my MPD24.


If all else fails look up a tutorial on using FPC (which is a great little VST for MPD/MPCs, but I am not going to go into that as I really only use it in live settings.
#9
Ok, the MPD18 is fully enabled in the program. That part was easy, thankfully. What I can't do now is record patterns. Every time I do it says I need an ASIO driver device to do so...

I was able to create patterns using the pre-made grooves but for some reason it wont let me record patterns. I figure I must have something ill-configured?

Do I use FPC to change the pad assignments? I'm sorry if I seem like I'm an idiot here, but I'm really trying.
Lefties Unite!
#13
It worked, but only once...I made a little pattern and it showed up in the playlist. I then erased it and tried to make some more. Now, though, when I record it records nothing. Sigh.
Lefties Unite!
#14
make sure you record in "song" mode and that you change patterns after each record. maybe look at a tutorial of recording midi in FL? I would do it but for some reason I can never get screen capture + audio to synch up for me...
#15
I don't want to record patterns in 'pattern' mode? Maybe that was the issue...brb lol
Lefties Unite!
#19
ok, I was able to make a single pattern again...now when i try to do pattern two it won't record and it just slows down the first pattern (pitch and tempo). This really shouldn't be so hard....I was ripping and rocking on my DR5 in like an hour.
Lefties Unite!
#20
I also noticed that in the step sequencer it changes names (originally was DFH sampler). After I record it turns into an untitled FPC. Too weird.
Lefties Unite!
#22
Ok I think I got it somewhat working. I am able to record parts and send them to the playlist (for now!).

My question now is this (oh boy), I usually first record the drum sequence with just the snare and drums. I then add the hi hats and cymbal crashed, etc.

I record the drum/snare first and make a pattern. First I tried to record the hi-hat as pattern 2, but as soon as I hit the pad the bass/snare dropped out of the audio and I lost my place. I then tried recording the hi hats over pattern one (like add to it), but I don't think I can do that either.

What I used to do on the DR5 is select how long I wanted the pattern to be (4 beats, 8 beats, etc) and then play it. The machine would then loop it and I'd play the next part over it, etc.

Can I do that? I don't think I'm skilled enough to play all the drum parts at once
Lefties Unite!
#23
Select the pattern in the playlist and use the pencil to click on the playlist to make them loop or the paint brush to just drag a huge amount and you should be alright. If it still drops out then let me know and I will mess with FL tommorow (I had that problem once but can't remeber what causes it)
#24
Yea, still doing it...let me know, I'll keep messing with it. Oddly, I can play the pattern back (not recording) and have no problem playing other drum parts over it. It is only when recording that it drops.

Afterwards if I play the two patterns together they both play, but they are obviously way out of sync since I can't hear one while I do the other.
Lefties Unite!
#25
Can anyone help me with this? I'm really held back by this issue
Lefties Unite!
#26
Found it!

If anyone needs to know, just click the little W button by the metronome (Blend notes). By default it is turned off. Click it and done!

[\crazy person]
Lefties Unite!
#27
Quote by ActofGod
Found it!

If anyone needs to know, just click the little W button by the metronome (Blend notes). By default it is turned off. Click it and done!

[\crazy person]


Thats great you got it. Sorry I totally forgot about (have crazy stuff going on right now)