#1
I just bought a new matched quad set of JJ 6l6 GC power tubes. I put them in my amp and as soon as turning the power switch on my amp made a loud popping sound.....weird.....after a few more minutes I switched my amp to standby on and all of a sudden the tubes started getting brighter blue and made another popping sound...and then started buzzing and crackling....then another pop and no more power And my fuse isn't blown.........PLEASE HELP!!!
#2
Did you make sure to insert the tubes in the same position as the previous ones? did you bias it at all?
Guitars:
LTD Alexi-600 White & Black
LTD Alexi-200 Black(Death Adder pickup & Gold OFR)
Agile Interceptor Pro 727 7-string
Jackson JS30RR rhoads
Jackson DKMGT
Squire telecaster

amps:
Bugera 6262 212 loaded with WGS veteran 30's
#4
Quote by Ultima117
Yeah. I didnt have a chance to bias it


biasing is very, very important.
#6
Well first of all you shouldn't of played it if you haven't biased it, and second of all, that would be a good idea, definitely now.
#7
It shouldn't be biased so hot that his tubes popped instantly.

Something else is wrong.
Everyone is entitled to an opinion.

Feel free to express yours so I can make an informed judgement about how stupid you are.
#8
Quote by Gundamnitpete
Did you make sure to insert the tubes in the same position as the previous ones? did you bias it at all?


I didn't even think you could put them in the wrong position, the pins only let you insert the valves in one position, no? :S
Although I only have experience with 6V6s so maybe other tubes aren't the same.
Quote by WtrPlyr
Quote by alans056
Maybe the price tag is clouding your judgment ?
yeah probably. Or the circuits.
#9
Quote by bubb_tubbs
It shouldn't be biased so hot that his tubes popped instantly.

Something else is wrong.


I never said that was the problem, I just said biasing is very important!
Last edited by Stryker636 at Apr 8, 2011,
#10
Different brand of tubes should be biased? No?
Reverbnation.com/offthewitness
#11
Quote by maddnotez
Different brand of tubes should be biased? No?


All tubes should be biased!
#12
Quote by PussyPunk182
I didn't even think you could put them in the wrong position, the pins only let you insert the valves in one position, no? :S
Although I only have experience with 6V6s so maybe other tubes aren't the same.

some bias probes don't have an internal "keyway", which means a tube could be inserted wrong.

but since he didnt bias it, that prolly didnt happen.


TS, is it on the 6l6 switch or el84?
Guitars:
LTD Alexi-600 White & Black
LTD Alexi-200 Black(Death Adder pickup & Gold OFR)
Agile Interceptor Pro 727 7-string
Jackson JS30RR rhoads
Jackson DKMGT
Squire telecaster

amps:
Bugera 6262 212 loaded with WGS veteran 30's
#13
it was still on the 6l6 switch...it had stock 6l6 tubes, so i figured replacing with 6l6's would be fine and would last long enough to bias....it started buzzing and making a weird crackling sound after the second pop, before they started to glow really blue and power shutoff...like i said too, the fuse isn't blown though and if you look at the tubes they look normal..........should i put the stock ones back in? I pulled them in the first place due to rust build up on the inside and outside of the tubes...
#14
how old is your amp? mine is an 07 date code and i've got no rust anywhere near my tubes. you don't happen to keep your amp outside do you? lol, j/k(i hope).


Tubes should glow blue when in use. That is a normal everyday thing, as long as they are not crazy bright, or red or something.

when you say no more power, do you mean that the power and standby lights don't come on? as the the entire amp is dead? or is there just no sound?

If the lights come on, try putting your old tubes in. where did you buy your new tubes from?
Guitars:
LTD Alexi-600 White & Black
LTD Alexi-200 Black(Death Adder pickup & Gold OFR)
Agile Interceptor Pro 727 7-string
Jackson JS30RR rhoads
Jackson DKMGT
Squire telecaster

amps:
Bugera 6262 212 loaded with WGS veteran 30's
Last edited by Gundamnitpete at Apr 8, 2011,
#15
the whole amp is dead...no more power And yeah ive had my amp for a year....bugera 6260 combo and there is rust on the tube, not terrible, but enough
#16
what is the date code? if it's earlier than mid 2008, then your amp might have the transformer clip problem. if that's the case, make a warranty call to bugera.

the date code is on the back, just below the power cord jack. mine reads "0712" which means 2007, 12th month (december).
Guitars:
LTD Alexi-600 White & Black
LTD Alexi-200 Black(Death Adder pickup & Gold OFR)
Agile Interceptor Pro 727 7-string
Jackson JS30RR rhoads
Jackson DKMGT
Squire telecaster

amps:
Bugera 6262 212 loaded with WGS veteran 30's
#18
i would give bugera a call or take it to a tech, they'll know more.

Although, might try just using a different power cord and wall socket, worth a shot. your computer uses the same kind of cable.
Guitars:
LTD Alexi-600 White & Black
LTD Alexi-200 Black(Death Adder pickup & Gold OFR)
Agile Interceptor Pro 727 7-string
Jackson JS30RR rhoads
Jackson DKMGT
Squire telecaster

amps:
Bugera 6262 212 loaded with WGS veteran 30's
#19
I put the stock tubes back in and nothin.....so i called american musical supply about my extended warranty !!!! and they told me to call monday cause their techs will be in and send it back so they can fix it....i guess bugera discontinued this amp so they'll have to fix it.....i guess at least i'll get it back working...... and american musical supply is my hometown so i can just drop it off
#20
Glad you didn't have to pony up the money to have it repaired. I wasn't sure how long those warranties were good for.
Everyone is entitled to an opinion.

Feel free to express yours so I can make an informed judgement about how stupid you are.
#21
Hey pete, I was just checkin children of bodom covers on youtube and it looks like you have one, follow the reaper!! nice! How on earth did you keep your amp that quiet?....my amp used to squeal on like 5 or 6 for the high gain channel
#22
It's because I kept the volume down, not a lot of stuff for feedback.
Guitars:
LTD Alexi-600 White & Black
LTD Alexi-200 Black(Death Adder pickup & Gold OFR)
Agile Interceptor Pro 727 7-string
Jackson JS30RR rhoads
Jackson DKMGT
Squire telecaster

amps:
Bugera 6262 212 loaded with WGS veteran 30's