#1
Ok so i bought emg 85/81s and put them into my shecter omen. They sounded fine in distortion but they sounded terrible in clean. They sounded kind of muddy i suppose? It was just an ugly sound. I had a friend look at them and he messed with something and that sound went away, but now when i turn the volume knob, i get a scratching/rumbling sound. I really don't know what to do because im not very knowledgeable about pickups. Can someone help me?!?!
#2
Maybe not keep the volume all the way up
Quote by BrokenDstring
Just smear poo all over everything he owns. Trade him for a fake les paul. Turtle his backpack. Bang his friends.

THIS IS WHAT THE PIT IS. RETARDED THREADS. ALL DAY, EVERY GOD DAMN DAY.
#3
Quote by ishmonkey
Maybe not keep the volume all the way up

That would work but this problem shouldnt be happening in the first place. I want to fix it completely and not just cover it up.
#5
It's not just a dirty pot? Have you tried getting some switch cleaner on it and cleaning it?
#6
What about the ground wire did you check that?
Quote by BrokenDstring
Just smear poo all over everything he owns. Trade him for a fake les paul. Turtle his backpack. Bang his friends.

THIS IS WHAT THE PIT IS. RETARDED THREADS. ALL DAY, EVERY GOD DAMN DAY.
#7
Quote by Bidley
It's not just a dirty pot? Have you tried getting some switch cleaner on it and cleaning it?

I dont know if its dirty or not. What would i use to clean it? And if that doesnt work then what?
#8
Use switch cleaner. If that doesn't work then try switching the pot for one you know works well. Also, try the ground wire, as has been said.
#9
Quote by Bidley
Use switch cleaner. If that doesn't work then try switching the pot for one you know works well. Also, try the ground wire, as has been said.

Alright sweet. Ill try that soon. If that doesnt work i might just take it in.
#10
already been suggested but clean your pots, then if that doesn't work maybe invest in some new ones.
Belief is a beautiful armour but makes for the heaviest sword.