#1
I bought Lord of The Rings Battle For Middle-Earth 2 the other day and it arrived today. I installed it as normal but as soon as i went to run it it said it'd stopped working . I looked online and it recommended i tried compatibility mode for Windows XP, i tried this, it then said "Please insert correct DVD-ROM" and closed. I then updated the gamr with the latest patch (1.06) and it still doesn't work.

Can someone please help?

I'm running Windows 7 64-bit
#2
I can't help, but just to let you know it's a beastly game so it's worth the trouble of getting it fixed.
#3
Quote by Gu1tar K1d
I can't help, but just to let you know it's a beastly game so it's worth the trouble of getting it fixed.

Yeah definatly. I used to play it on my Laptop which had Windows Vista Home Premium 32-bit and some crappy Xpress graphics Card.
#5
How far does it get? Crash before loading or do you get the splash screen first?
#6
Quote by JackalUK
How far does it get? Crash before loading or do you get the splash screen first?

It comes up with the Logo window for loading but then it just stops working, it's really frustrating .
#7
Quote by webiste above


Do a search for AppData. Then from there goto Roaming --> My Battle for Middle Earth 2 Files.
If you find it is empty, then create a folder called Maps.
Also, open up Notepad and copy the following into it:
Quote: AllHealthBars = yes
AmbientVolume = 81.000000
AnimationLOD = High
AudioLOD = Low
Brightness = 50
DecalLOD = High
EffectsLOD = Medium
FlashTutorial = 0
GameSpyIPAddress =
HasSeenLogoMovies = yes
IdealStaticGameLOD = Low
ModelLOD = Medium
MovieVolume = 70.000000
MusicVolume = 78.000000
Resolution = 1024 768
SFXVolume = 80.000000
ScrollFactor = 64
SendDelay = no
ShaderLOD = Low
ShadowLOD = Low
StaticGameLOD = Custom
TerrainLOD = Medium
TextureQualityLOD = High
TimesInGame = 59
UseEAX3 = no
VoiceVolume = 69.000000
WaterLOD = Medium

Then go File > Save As and name it Options.ini, save it into the same folder you placed the Maps folder to.


Try that one, chances are your resolution is too high and the game is crashing out.
#8
Quote by JackalUK
Try that one, chances are your resolution is too high and the game is crashing out.

That actually surprisingly worked O.o

Thanks alot! EA really need to get their act together.
#9
Quote by Afroboy267
That actually surprisingly worked O.o

Thanks alot! EA really need to get their act together.


I'm pretty sure EA can't do anything to any of their LOTR games since their deal to use the Lord of the Rings name expired, or something like that.
#11
Quote by Afroboy267
That actually surprisingly worked O.o

Thanks alot! EA really need to get their act together.


Quote by GLP_Arclite
Pooping is well good though, to be fair.


I've got a handle on the fiction.

I'm losing my grip, 'cos I'm losing my fingers.
#12
Quote by Baby Joel
It's not EA it's Windows 7

it's exactly this

it's because W7 has a stupid resolution compared to the other OS's so some games crash, i've had a few, notably RA2 which i was a bit peeved about, i love that game!

also try http://www.systemrequirementslab.com/cyri/ in future before you buy any games.
Belief is a beautiful armour but makes for the heaviest sword.
#13
Quote by Dempsey68
it's exactly this

it's because W7 has a stupid resolution compared to the other OS's so some games crash, i've had a few, notably RA2 which i was a bit peeved about, i love that game!

also try http://www.systemrequirementslab.com/cyri/ in future before you buy any games.


I've never used Windows 7, but I've found a lot of old games don't run with Dual cores, like Dungeon Keeper 2.

However, with admin priviliges, you can tell the game to only run from one core.

Just thought it was worth throwing in.
Quote by GLP_Arclite
Pooping is well good though, to be fair.


I've got a handle on the fiction.

I'm losing my grip, 'cos I'm losing my fingers.