#1
So my pedal lights up and no noise is coming out of my amp but sometimes there
is a very light sound which will eventually cut out.My cables are perfect and have tried
many different batteries.Just wondering if its toast or something i can fix
thanks for the help
#2
Have you visually inspected the electronics to see if anything is visibly fried or disconnected? Have you ever got the burnt electronics smell from it?
#3
ya all the wires are still solder on tight and i never get that smell.when i turn the knobs
on the pedal it makes almost like a warping noise or a dj spinning...just no noise comes
through when i play
#4
You broke a boss pedal? That's impressive, clearly you are a greater force than the apocalypse itself
My Gear:
BC Rich Gunslinger Retro Blade
Vintage V100 Paradise + SD Alnico Pro Slash APH-2's
1963 Burns Short Scale Jazz Guitar
Dean Performer Florentine
Bugera 6260
Orange Micro Terror + cab
Digitech Bad Monkey
Zoom G2G
#6
Quote by StratmanSG 45
ya all the wires are still solder on tight and i never get that smell.when i turn the knobs
on the pedal it makes almost like a warping noise or a dj spinning...just no noise comes
through when i play

take the back off the pedal, and pull out the circuit card. look at it to make sure nothing looks burnt or damaged. if you arent sure what you are looking at, take a high quality picture and post it on here. sometimes it is something simple like a blown cap.
#8
if there was something small fried like a cap or a resistor, it would probably be close to the pedals volume knob.

Does the LED light up? If so, it's NOT a problem with the power

Does the pedal cut your guitar signal on both it's on and off positions? If your guitar sounds alright when the pedal is bypassed, it's NOT a problem with either of the jacks (or their electronics)