#1
Hey!

So when I record in reaper, I had track 1 as a backing track. I downloaded a backing track and placed it there, everything was fine. Then I created track 2 as the track Id play on it. I armed it and everything.

When I pushed the record button, and played along the backtrack, the playback would sound horrendous because the recorded track was recorded in delay. After I clicked record, the track didnt instantly start to record, but a little late. So this delay actually ended up giving the track a head start when both tracks are played back at the same time.

Also I have no clue on cutting a track in half wherever I want to from. Any help on that?

Also everytime I try to set the track at a certain point (move it around) it only goes to the nearest metronome click and not exactly where I want it to go. Any help on that too?

Thanks in advance! Problem #1. is my main issue, but any help on any of the issues is welcome! Thanks again!
#2
Sounds like a latency issue. Assuming you're using an interface, it's probably from that. You need to adjust the sample size and such to fix that. Googling it should help, or take a look at the manual that came with the interface. Reaper might even have a latency delay compensation tool in it, but I've never used it extensively, so I don't know.

As for the second, usually you can just right click at the point you want to split and click "split". Well, at least that's how it was in Cubase and Ableton.

To move it to a more precise spot, zoom in, which can usually be done by clicking someone on the track and pressing "+" or "-" or sometimes the mouse wheel. Of course, this could be different in Reaper.

You should really just go find a good tutorial on Reaper and look up on it.
#3
Quote by CrossBack7
Sounds like a latency issue. Assuming you're using an interface, it's probably from that. You need to adjust the sample size and such to fix that. Googling it should help, or take a look at the manual that came with the interface. Reaper might even have a latency delay compensation tool in it, but I've never used it extensively, so I don't know.

As for the second, usually you can just right click at the point you want to split and click "split". Well, at least that's how it was in Cubase and Ableton.

To move it to a more precise spot, zoom in, which can usually be done by clicking someone on the track and pressing "+" or "-" or sometimes the mouse wheel. Of course, this could be different in Reaper.

You should really just go find a good tutorial on Reaper and look up on it.


So I assume its a latency issue. Happy that I got a name for my problem (Im really a novice at recording)! Ill go check the manual, but if anyone knows what Im supposed to do, Id be really pleased!

About the moving to the precise spot.. I guess I described it a bit wrong. What Reaper seems to do is that when I try to drag the piece forward/backward, it only moves a metronome beat at a time, you know. So I cant move it "freely".

EDIT: In Reapers Preferences:

Sample Format: 16 bit (other options: 24, 32 bit)
Samplerate: 44100 Hz
Buffers: 8 x 1024 samples
(latency: 185 ms)


What should I change, and into what?
Last edited by fc89konkari at May 24, 2011,
#4
There ya go. Try toying with the buffers. The lower the buffer size, the lower the latency, though you'll get some clipping and such if you go too low, so you're going to have to kind of mess with it. Hopefully, that will decrease the latency to a point where it won't really be noticeable.

And I get what you mean for the precise point, but I'm not sure how to get it to move "freely" as you say. I always just zoomed in so that it would make the metronome marks more precise. Like, it breaks the bars into smaller and smaller bars so that eventually you can move it to pretty much any spot with it being only maybe a few milliseconds off.
#5
The latency thing is a pain, but what I do is just move the recorded track back a couple milliseconds until it's in time. Not as painstaking as it sounds unless you're doing some ridiculous syncopated/weird time stuff.

The moving freely thing is an easy fix.

in the top left corner, there should be a button that has like a noughts and crosses board. Click that and the metronome clicks will dissappear from your sequencer and you can slide the tracks anywhere you want!

To split a track, left click where you want to split, then right click and go down to "spit items at cursor".

make sure you only have the track you want split selected. i always accidentally cut like 4 tracks :L

Hope that helps
#6
ok this mightn't be a latency issue.
The splitting thing and moving freely I did get already, thanks!

But Ill try explaining again.

When I click record, the recorded line doesnt appear immediately, but when I play during recording, the guitar signal gets on tape nearly instantly. So actually the recording line (where everything appears during recording when I play) is coming late! Its not coming wrong or anything, just late. So the guitar is actually coming too EARLY onto the final piece. I know I can just move it into place afterwoods but its a PITA. So when I record something, if I decide to wait for 4 beats before I play and then start playing, the guitar comes early, showing that I only waited for eg. 2 beats, the first 2 were cut.

Hard to explain... I know. Sorry and thanks for any help!
#7
That is kind of a weird one. Have you tried recording with and without the metronome? Are you sure you have the very beginning of the track selected? Otherwise, I'm not sure what else to say except for the latency.
#8
not sure about you latency issue, make sure that monitoring is off on the track (its the little speaker icon near the bottom of the track) this could result in a delayed sound.

As for your snap to grid problem, Reaper automatically sets the GUI to Snap mode and by clicking the magnet icon in the top panel you can disable the snap to grid mode and move a waveform freely.

Press "S" on your keyboard to split.
---------------------------------------------------------------------------
'04 Tony Iommi Signature SG
'66 Harmony Bobkat
#9
Quote by CrossBack7
That is kind of a weird one. Have you tried recording with and without the metronome? Are you sure you have the very beginning of the track selected? Otherwise, I'm not sure what else to say except for the latency.

Yes, and yes. Absolutely sure.

Quote by abitofinger
not sure about you latency issue, make sure that monitoring is off on the track (its the little speaker icon near the bottom of the track) this could result in a delayed sound.

It is off. Absolutely sure.

Quote by abitofinger
As for your snap to grid problem, Reaper automatically sets the GUI to Snap mode and by clicking the magnet icon in the top panel you can disable the snap to grid mode and move a waveform freely.

Press "S" on your keyboard to split.

I just tried this, a major thanks!!

I just thought that does Reaper work so, that when I press record, it only starts recording after it hears a noise of a certain decibel? This is a really bad guess but just thinking...
#10
^That is definitely not the problem!

Sounds like you've got a count in set up...

Try going into options > Metronome settings and see if you have the count-in box checked.

Also, if your cursor/bar line thing is anywhere after where you want to record from, it can snap ahead to where the line is, so make sure it's at a point before the spot you want to record at!

Any help?
#11
Quote by shmeegle
^That is definitely not the problem!

Sounds like you've got a count in set up...

Try going into options > Metronome settings and see if you have the count-in box checked.

Also, if your cursor/bar line thing is anywhere after where you want to record from, it can snap ahead to where the line is, so make sure it's at a point before the spot you want to record at!

Any help?

Count-in is not checked.

Always when I record, I have the bar thingy maby around 8 beats before the actual part that I want to record (im recording with a backing track).
#13
Some guy recommended to download "ASIO4ALL" drivers but they dont seem to work with me (idk if it fixes the problem or not but just doesnt work).

Another question about REAPER! :

When Ive recorded something, how can I make it into an mp3 or waw. file?
#14
That I can help with!

What I do is Time select the track (with the cursor so it's shaded in)
Then go to File > Render

check the render time selection dot/box thing, set your output folder and file type and hit render.

I think you can render it as .wav but not .mp3. Just download NCH switch converter and that'll take care of that!
#16
The problem with ASIO4ALL is that when I go to options -> preferences to select the driver, ASIO4ALL wont give me Fast Track Ultra as inputs, neither does it give it for outputs, so I cant really use it.. dunno...

But thanks for the rendering help! I just got the file as waw. AND mp3 (by the LAME thing). Ill upload it once I get from school as I got to go now. I just recorded a cover with 1 guitar (double tracked) and a backing track that I downloaded of Unholy Confessions. Nothing too special. I managed, but because of the latency, I had to replace every single clip I recorded and also because I was new to Reaper at the start, this took me about 5 hours to do. (app.)

Cheers!