#1
After looking at a bunch of pictures on my Amp Head it just occurred to me......mine is backwards O.o Just look:
Mine
(Invalid img)

and someone else's


I figure since I'm trying to open it and see if I can figure out why only half of it is working, I might as well try and switch it the other way (https://www.ultimate-guitar.com/forum/showthread.php?t=1446866). Only thing is.......HOW DO I OPEN THIS??? It's like a frickin' brick. any help please?
#2
wait... what?

I don't see a difference and I don't understand.
Quote by UraniYum
Fuck you I'm trying to be caring and shit


Quote by Cb4rabid
Okay guys, I have a confession to make. Not really a confession since it's something that's been bugging me for awhile but I've always been in denial about it.

**** you gilly, it's not what you think
#4
on mine the tolex is back a lot and on their's the tolex comes out in towards the middle, i don't really have a picture of it, but the back of my amp head has the tolex poofing in towards the middle like that one; if it helps you notice it, above the on/off switch on mine, you can see inside of the amp, while on their's you can't
#5
I suspect one of them has been retolex'd. Don't worry about it.
In the bass chat:

<Jon> take the quote of me out your sig plx
<Jon> i hate seeing what i said around lol


Leader of the Bass Militia PM to join!



And now on BANDCAMP!


Officially the funniest member of the Bass Forum.
#7
Well, that's a relief....any idea on how to open it though? Cause the Bright side doesn't work so, I figured I'd open it up and see if I could figure out what was wrong with it....
#8
Take a picture of the back? There should be screws on it somewhere.
In the bass chat:

<Jon> take the quote of me out your sig plx
<Jon> i hate seeing what i said around lol


Leader of the Bass Militia PM to join!



And now on BANDCAMP!


Officially the funniest member of the Bass Forum.
#9
There's screws on the front too, I unscrewed those but it hasn't moved at all. I was about to unscrew the one's on the back but I didn't want to unscrew those then it all falls apart of something.....
(Invalid img)


(Invalid img)
Attachments:
Pic4.JPG
Pic5.JPG
#11
Okay, so I unscrewed the bottom screws (thanks for the clue there Delirium) and I opened it up, so here's some pictures of the inside if any of you guys can see something popping out as wrong with it, that might cause the Bright side not to work....
(Invalid img)

(Invalid img)

(Invalid img)

(Invalid img)

(Invalid img)

(Invalid img)

(Invalid img)

(Invalid img)

(Invalid img)

I'm not really sure what to look for, so I kinda took a bunch of pictures........help please?
#12
Maybe yours is a left-handed amp?
"Maybe this world is another planet's hell?" - Aldous Huxley
#14
Why not? Manufacturers make left-handed instruments. Maybe some guy at the Kustom factory switched the controls so left-handed people wouldn't feel left out?
"Maybe this world is another planet's hell?" - Aldous Huxley
#16
Quote by FatalGear41
Maybe yours is a left-handed amp?




Your sense of humour is certainly interesting.
Quote by UraniYum
Fuck you I'm trying to be caring and shit


Quote by Cb4rabid
Okay guys, I have a confession to make. Not really a confession since it's something that's been bugging me for awhile but I've always been in denial about it.

**** you gilly, it's not what you think