#1
Just got one yesterday but rather disappointed.

Clean channel sounds fine, if i put a distortion pedal in the input and play through the clean channel it sounds fine.

My problem is when i switch to the overdrive channel it sounds really muffled, like someones put a big blanket over it or something. Ive tried turning the bass down/treble up and all the rest of it.

When i watched Youtube vids of this amp on the overdrive channel it sounded fine.

Anyone else have this problem/can offer advice??
#3
Quote by GS LEAD 5
Fiddle with the ISF knob. Cut bass and mids, boost treble.


Done that.

Still sounds shit
#5
Lol, if you've fiddled with all the knobs and your sure it has to be some technical problem with the amp, your just wasting you time by posting here and not sending it back. It's obviously something wrong with the amp, so we can't help you there. Not to meantion it wouldn't be wise to even "touch" the amp more seriously unless you'd want to wipe out your warranty.
#6
My HT5 sounds like total crap with a pedal on the distortion channel. Also I think the distortion channel sounds like crap without a pedal. I just use a pedal in front of the clean channel to get round this and it sounds decent.
#7
Quote by NorthernPaul
My HT5 sounds like total crap with a pedal on the distortion channel. Also I think the distortion channel sounds like crap without a pedal. I just use a pedal in front of the clean channel to get round this and it sounds decent.


How does the distortion on the HT5 compare to your Microcube? Stupid question but I'm thinking of getting a HT-5 and I have a cube.
#8
Quote by NorthernPaul
My HT5 sounds like total crap with a pedal on the distortion channel. Also I think the distortion channel sounds like crap without a pedal. I just use a pedal in front of the clean channel to get round this and it sounds decent.


Yeah it sounds fine with my DS-1 on the clean channel but when i change the amp to the o/d channel and turn my pedal off (i.e just using the amps own overdrive) thats when i have my problems.

im not sure if thats how its supposed to sound (disappointed if it is) or whether ive got a duff amp. Like i say, its just really bassy and kinda muffled. Didnt sound like that on youtube vids ive watched.
#9
I find it strange that people here are dissapointed with the distortion channel, especially on this amp. Blackstar are supposed to be a make founded upon marshall ex-workers (if I'm not mistaken), so the amp it supposed to be very similar (including the sound) to a marshall, and from videos and reviews I've seen, the marshall feel is definatly there and they are great great amps.

I wonder if some are escaping out the factory with problems.
#10
it's only as good as the speaker.

if it's new, you probably need to break in the speaker.

play at full blast for 20 hours and report back.
#11
yeh, probably need the speaker breaking in, you never get the best out of an speaker when it`s brand new. My HT5 took a while before it came to life. Same with my stereo speakers, same with my headphones.
Last edited by Troop of Doom at Jun 3, 2011,
#12
Quote by Troop of Doom
yeh, probably need the speaker breaking in, you never get the best out of an speaker when it`s brand new. My HT5 took a while before it came to life. Same with my stereo speakers, same with my headphones.


Interesting, interesting.

Im gonna blast the shit out of it tonight