#1
So my Fender Hot Rod Deluxe is buzzing when the volume is too high, i have it on the clean channel on 2 which is about the lowest it can go before it drops off, and my strat at 6 before u hear the buzzing. Ive tried searching up reasons why it could be buzzing/rattling, i checked the tubes and everything inside and nothing seems loose, would anyone have any suggestions as to why im hearing this buzzing sound? it happens when the volume is low or when i hit a chord and its really annoying to me at since i hear these things... i couldn't even fully enjoy my new reverb pedal today since the buzzing was driving me insane =/

also any reason to believe standing on top of the amp may be a reason for this? not that i stood on it but the bass player in the band im in randomly likes to stand on it (im gonna kill him if he does it again though b/c that shit aint cute...) and this never happened before, the tubes are about 6 or 7 months old too i just hope i dont have to replace them...

any help would be appreciated!
My Gear:

2010 Fender American Deluxe Sunburst Stratocaster HSS (1st Choice)
Ibanez RG 5EX1 (2nd Choice)
Fender Hot Rod Deluxe III
Dunlop Crybaby Wah Pedal
Digitech Time Bender Delay
Boss BF-2 Flanger)
EHX Germanium 4 Big Muff Pi
#2
have you tried it in different rooms? I've noticed sometimes my amp will buzz in one room, then I play it somewhere else and the buzz is gone.

otherwise could be worth checking your guitar is grounded properly.

and, could it be possible that it is just a normal hum from the single coil pickups on your strat?
---
#3
ive tried it in two rooms but ill try the rest of the house, and i used two guitars and both times it kept buzzing, and i have noiseless sing coils on my strat its not the type of buzzing that ud get from regular single coils =/ its more of like a rattle that i hear coming from the amp but nothing inside is loose so this is weird, i do carry it around a lot though so i wouldnt be surprised if thats the reason why i just hope i can fix it without having to send it in for repairs
My Gear:

2010 Fender American Deluxe Sunburst Stratocaster HSS (1st Choice)
Ibanez RG 5EX1 (2nd Choice)
Fender Hot Rod Deluxe III
Dunlop Crybaby Wah Pedal
Digitech Time Bender Delay
Boss BF-2 Flanger)
EHX Germanium 4 Big Muff Pi
#4
simple idea here that works for me. have you tried to tighten all the screws? and i do mean all of them. even ones that are for the feet for example. try to get a few turns of the screwdriver on every single screw you can find. it works for me most of the time
#5
i tightened them right now again just in case but nothing felt loose ill check it tomorrow since everyones sleeping right now :S oh another thing, at first the humming/buzzing happened when i played certain notes like i noticed it whenever i played a C# and then all the other notes would not buzz but now its more notes
My Gear:

2010 Fender American Deluxe Sunburst Stratocaster HSS (1st Choice)
Ibanez RG 5EX1 (2nd Choice)
Fender Hot Rod Deluxe III
Dunlop Crybaby Wah Pedal
Digitech Time Bender Delay
Boss BF-2 Flanger)
EHX Germanium 4 Big Muff Pi