#1
Hi, I have a TSL 602 and sometimes when I'm playing the volume turns down and the amp becomes silent.
I switched the tube locations and I think its not a tube problem because I noticed the ECC83 tube on the right of the amp turns off, but I'm not sure about it.
I know it sounds stupid but why cant i find the 4th ECC83 ? I can only see 3 of them, is that the thing that has some sort of a metal cover over it ?
Can anyone help me ?
Guitar : Cort X-TH ( EMG 81-85 )
Amp : Marshall TSL-602
Effects : Boss MT-2, Boss NS-2
#2
Yes that cover comes off. Just push it down a bit and twist.
Gilchrist custom
Yamaha SBG500
Telecasters
Randall RM100 & RM20
Marshall JTM45 clone
Marshall JCM900 4102 (modded)
Marshall 18W clone
Fender 5F1 Champ clone
Atomic Amplifire
Marshall 1960A
Boss GT-100


Cathbard Amplification
My band
#3
Thanks, and now the real problem, should i have to retube or is there a problem with my amp ?
Guitar : Cort X-TH ( EMG 81-85 )
Amp : Marshall TSL-602
Effects : Boss MT-2, Boss NS-2
#4
tube time!

sounds like you need some new tubes
My Gear
Guitars:
-Gibson Les Paul Studio
-Ibanez "lawsuit" Les Paul
-Ibanez S470
-PRS SE Custom

Amp:
Marshall TSL100
Marshall 1960a cab

Effects:
Dunlop 535q wah
Visual Sound Liquid Chorus

Pickups:
Guitarforce
MHD
#5
Does it make any noises as it dies or does it just fade away to nothing?
Gilchrist custom
Yamaha SBG500
Telecasters
Randall RM100 & RM20
Marshall JTM45 clone
Marshall JCM900 4102 (modded)
Marshall 18W clone
Fender 5F1 Champ clone
Atomic Amplifire
Marshall 1960A
Boss GT-100


Cathbard Amplification
My band
#6
no it doesn't make any noises, it just fades away, its like turning the volume down to zero
Guitar : Cort X-TH ( EMG 81-85 )
Amp : Marshall TSL-602
Effects : Boss MT-2, Boss NS-2
#7
BUMP!
Anyone ?
Guitar : Cort X-TH ( EMG 81-85 )
Amp : Marshall TSL-602
Effects : Boss MT-2, Boss NS-2
#8
My guess is tubes. Usually if a filter cap goes you hear hum or other odd noises as it dies. It still could be those because of the way it fades - that's very cap-like.
Check all your tubes are seated properly. If they are, start replacing them with your spares - you do have spares don't you? My guess is power tubes.
Gilchrist custom
Yamaha SBG500
Telecasters
Randall RM100 & RM20
Marshall JTM45 clone
Marshall JCM900 4102 (modded)
Marshall 18W clone
Fender 5F1 Champ clone
Atomic Amplifire
Marshall 1960A
Boss GT-100


Cathbard Amplification
My band
#9
actually I don't have any spares, is it necessary to retube the preamp too or changing the tubes of power amp does it ?
as you know tubes are expensive, does retubing solves the problem or should I be concerned about bigger problems ?
-----------------------------------------
can I retube to some other set of tubes ?
If yes what would be the best combination of tubes for a clean sound and a good distorted sound ?
If I put some other kind of tubes do I have to bias the amp ?
Guitar : Cort X-TH ( EMG 81-85 )
Amp : Marshall TSL-602
Effects : Boss MT-2, Boss NS-2
Last edited by Philosophient at Jul 16, 2011,