#1
So basically after I set up my keyboard for midi in the Reaper program , every note I hit is noticeably "late". Like I hit the key and then it takes a couple milliseconds before the note sounds. I've used the keyboard as a midi controller for other DAW's and it does fine but in Reaper it's delayed.

Does anyone know how I can adjust the response or fix the problem?
Listen to jazz, it'll make you a better guitar player.


Whatever you do, stay creative
#2
Check out http://www.asio4all.com/, very low latency ASIO driver that will solve your problem. Within Reaper, set ASIO4ALL2 as your driver, your keyboard as the input and your speakers/soundcard/etc as the output.
#3
thanks so much, it works now.... Except for some reason I can't get a signal when I use my headphones now that Asio is the driver, I can on the computer speakers. Is there some way to set the output to headphones or something? Its not showing them as an option
Listen to jazz, it'll make you a better guitar player.


Whatever you do, stay creative
#4
It has my input options as HD AudioDigital in 1 and the other option is in 2
The options for the outputs are HD audio speaker 1-8. THose are the only options so how do I set my keyboard as the input and my speakers as the output?
Listen to jazz, it'll make you a better guitar player.


Whatever you do, stay creative
#5
Is it a USB midi controller and are they USB headphones?

Click the advanced options button (the wrench) in the bottom right of the ASIO4ALL window, and that should show you all the different inputs and outputs you have. From there, turn on the input you want to use as well as the different outputs you want. If youve got USB headphones, you'll have to open the asio preferences and switch to them every time you go from speakers to headphones because usb headphones act as their own soundcard/device.