#1
i have an alesis dm6 electric drum kit via midi to usb, and i record drums with it on mixcraft with addictive drums as the vsti, and it worked perfectly, everyhting was mapped correctly and everything, but recently i have no clue why, but after maybe a week of not doing it, i plugged in my drum kit and it said downloading drivers for some reason and it recognized my Drum kit as a usb composite device, i didn't think anything of it, but when i tried playing it didn't work, it wouldn't play a thing, the e drums are working because they register on the actual DM6 module, but they wont work at all on mixcraft. i tried using a different vsti( a piano) and still nothing, so that eliminates the possibly of addictive drums being the problem. i used several usb 2.0 cords and nothing, so either its mixcraft, or because my computer thinks its a composite device. when i plug it in and out it was "a midi controller has changed" or something, so it recognizes its a midi controller, but i don't know why it wont play. any help? advice? Thanks!