#1
So I changed the power tubes in my Orange ad30tc and now it isn't very loud. it won't distort when turning the volume up. I have taken the tubes out and reseated them multiple times to no avail. All of the tubes light up, including the preamp tubes which were changed about 9 months ago. The only thing I haven't changed is the rectifier. Could that be the culprit?
.
.
Gold jacket, green jacket, who gives a shit?

.
.
#2
Did you bias the amp for the new tubes? Sounds like its biased too cold for the new set.
WTLTL 2011
#3
its a cathode baised amp, so I didn't bias it.
.
.
Gold jacket, green jacket, who gives a shit?

.
.
#4
Put the old ones in and see if it's doing the same thing. Rule out the tubes or the amp.
#5
The old ones play at the usual volume but crackle a lot.
.
.
Gold jacket, green jacket, who gives a shit?

.
.
#6
Are you confident that you have the correct replacement tubes?
You might have gotten a dud. Take them to a shop and have them checked - or exchange them.
#7
yes, i'm 100% positive they are el84's.

thanks for the help.
.
.
Gold jacket, green jacket, who gives a shit?

.
.
#8
Quote by kingbabyduck
its a cathode baised amp, so I didn't bias it.


Alright, then I don't know
WTLTL 2011
#9
I'd say you bought some dodgey valves. Take them back and exchange them.
Gilchrist custom
Yamaha SBG500
Telecasters
Randall RM100 & RM20
Marshall JTM45 clone
Marshall JCM900 4102 (modded)
Marshall 18W clone
Fender 5F1 Champ clone
Atomic Amplifire
Marshall 1960A
Boss GT-100


Cathbard Amplification
My band
#10
Did you get ones that are rated for the fixed bias range in your amp?
Quote by fly135
Just because one has tone suck it doesn't mean one's tone sucks.
#11
Quote by Dilberto
Did you get ones that are rated for the fixed bias range in your amp?

The AD30 has a 335V B+ and a 150 ohm bias resistor, they should be loafing. If any EL84 can't handle that configuration they deserve to be in the bin.
Gilchrist custom
Yamaha SBG500
Telecasters
Randall RM100 & RM20
Marshall JTM45 clone
Marshall JCM900 4102 (modded)
Marshall 18W clone
Fender 5F1 Champ clone
Atomic Amplifire
Marshall 1960A
Boss GT-100


Cathbard Amplification
My band
#12
Quote by Cathbard
The AD30 has a 335V B+ and a 150 ohm bias resistor, they should be loafing. If any EL84 can't handle that configuration they deserve to be in the bin.


Fair enough, I wasn't sure if they were like Mesas that you buy pre-rated.
Quote by fly135
Just because one has tone suck it doesn't mean one's tone sucks.
#13
I purchased some 12AX7's recently and had a similar experience- they all lit up, after testing every single one in every single position two of them just produced about half volume. Maybe you got the same thing going on. Get some JJ's... those are legit.
#14
Ya I bought my tubes through the tube store. Maybe it wasn't such a good idea to buy their own brand, haha.
.
.
Gold jacket, green jacket, who gives a shit?

.
.