#1
Exactly what the title says, my amp won't turn on. It's a Peavey Vypyr 75W. I have tried a different power chord and using a different outlet but it still won't turn on. It won't even make a sound nor will the lights turn on. Do you have any idea whats wrong? or if you have a Vypyr, has this happened to you?

Help is much appreciated, Adam
Guitars
Washburn A20V 1981
Stagg SG300
BC Rich DLXJRVO
Ibanez Iceman
Jackson King V
Epiphone Special II
Epiphone Embassy IV
Martin D-16RGT
Ibanez EW20WNE
#2
If you're getting absolutely zero power when you flip the switch, then the first thing I'd check is the switch.
"Maybe this world is another planet's hell?" - Aldous Huxley
#3
Quote by FatalGear41
If you're getting absolutely zero power when you flip the switch, then the first thing I'd check is the switch.


I agree with this, and if not the switch, the component right after it, which should be the input transformer (pray for it being the switch cause the transformer is way more expensive and a little more difficult to fix xD)
#4
Vypyrs are having problems with their software, but I suspect this to be something internally.
#6
Well I have no idea what most of you are talking about but I found out I have a warranty on it still, thanks a lot anyways - Adam
Guitars
Washburn A20V 1981
Stagg SG300
BC Rich DLXJRVO
Ibanez Iceman
Jackson King V
Epiphone Special II
Epiphone Embassy IV
Martin D-16RGT
Ibanez EW20WNE
#7
My friend had a similar problem with his Vypyr, it was the fuse.

Take it back where you got it and get the warranty checked out.
Quote by DeathByDestroyr
What the hell is a G&L.



Quote by Flux'D
Gay & Lesbian I think, the box smelled funny
Greg what did you send me??