#1
So here's the thing, I bought a Mesa/Boogie Mark III combo used on the internet. It arrived today, there's one thing though: the speaker seems to be ****ing broken. It works fine when I plug an external cabinet, but there's no sound at all if I plug in in the built in one. Could there be any rational explanation to this, or did I just get ****ed?

Shipping damage is very unlikely, as there seemed to be no exterior damage.
Gear as 2015:
Ibanez PGM401
Music Man JP6 (for sale)
Music Man Axis (for sale)
Fender American Deluxe Stratocaster
Ibanez EW Acoustic Steel string
Crappy Cort Acoustic 12-string
NI Rig Kontrol 3 & Guitar Rig 5
#2
You may have got screwed, or the owner hadn't played it in a long time.

How much did you pay for it? It doesn't seem like that big a deal to me. Just change the speaker.
Quote by DeathByDestroyr
What the hell is a G&L.



Quote by Flux'D
Gay & Lesbian I think, the box smelled funny
Greg what did you send me??
#3
Vad sa dom om förstärkaren när du faktiskt köpte den? Köpte du den från utomlands?
Quote by Wisthekiller
How does one safely remove the smell of a corpse from a banjo?
#4
check the connections to the speaker, could just be faulty wiring.


i wouldn't turn it on if there isn't a speaker connected if i was you
#5
I paid $1300 for it (might seem a lot to you guys, but in Sweden musical equipment is very expensive, used or new)... how much would a new speaker cost?

Bought it online from: http://www.blocket.se/stockholm/Mesa_Boogie_Mark_III_Combo__Greenstripe__35760196.htm?ca=8&w=3&last=1

doesn't say anything about a broken speaker!
Gear as 2015:
Ibanez PGM401
Music Man JP6 (for sale)
Music Man Axis (for sale)
Fender American Deluxe Stratocaster
Ibanez EW Acoustic Steel string
Crappy Cort Acoustic 12-string
NI Rig Kontrol 3 & Guitar Rig 5
Last edited by Joey Radical at Sep 27, 2011,
#6
Quote by Kalo Hanaka
Vad sa dom om förstärkaren när du faktiskt köpte den? Köpte du den från utomlands?


Kan du posta ditt meddelande på engelska, tack? Detta är en engelskspråkig ombord, kan du få i trubbel för att inte publicera på engelska.

Anyway, why don't you replace the speaker?
NT

BE QUICK OR BE DEAD SON
#7
Quote by NosralTserrof
Kan du posta ditt meddelande på engelska, tack? Detta är en engelskspråkig ombord, kan du få i trubbel för att inte publicera på engelska.

Anyway, why don't you replace the speaker?



Never had any trouble with it before... And it's easier to post/understand in ones native language when the opportunity exists.


OT: Jag tror att det skulle kunna bli rätt dyrt att skaffa en ny högtalare, och få det hela bytt i en butik, såvida man nu inte är rejält bundis med dom som jobbar där... Kanske du kan dra iväg till Musikbörsen i Örebro och fråga dom om en 12 tums högtalare och montering?
Quote by Wisthekiller
How does one safely remove the smell of a corpse from a banjo?
Last edited by Kalo Hanaka at Sep 27, 2011,
#8
Can you just verify that the speaker is connected. Speakers rarely just die. Busted cone - I could understand.

+1 to whomever said not to run the amp without a speaker load. Running it at a very low volume for a very short period of time simply to test should be a OK.
#9
Its pretty unlikely that the speaker is 'broken' and not producing sound... Generally no matter how bad a speaker is messed up it will at least buzz...

Check connections.
Quote by Cathbard
Quote by Raijouta
Unless its electronic drums.

BURN THE WITCH!!!!!
#10
What's this "cone" you speak of? I don't have a very broad knowledge of technical terms, I'm afraid.

Ska fan ringa börsen och se vad de säger! Annars har jag nog en bekant som kan byta högtalaren, bara jag beställer den själv.
Gear as 2015:
Ibanez PGM401
Music Man JP6 (for sale)
Music Man Axis (for sale)
Fender American Deluxe Stratocaster
Ibanez EW Acoustic Steel string
Crappy Cort Acoustic 12-string
NI Rig Kontrol 3 & Guitar Rig 5
#11
Högtalaren är formad som en kon, är nog det dom syftar på.

Pröva att kolla om det är några sladdar eller sådant som sitter löst. Hade det problemet en gång förr. Satte bara tillbaks sladden, och det fungerade exakt som det skulle.
Quote by Wisthekiller
How does one safely remove the smell of a corpse from a banjo?
#12
The cone is the part that looks like a cone.
Gilchrist custom
Yamaha SBG500
Telecasters
Randall RM100 & RM20
Marshall JTM45 clone
Marshall JCM900 4102 (modded)
Marshall 18W clone
Fender 5F1 Champ clone
Atomic Amplifire
Marshall 1960A
Boss GT-100


Cathbard Amplification
My band
#13
I am officially an idiot. (referring to the cone-thing).

Thanks, I'll check all connections.
Gear as 2015:
Ibanez PGM401
Music Man JP6 (for sale)
Music Man Axis (for sale)
Fender American Deluxe Stratocaster
Ibanez EW Acoustic Steel string
Crappy Cort Acoustic 12-string
NI Rig Kontrol 3 & Guitar Rig 5
#14
Quote by Cathbard
The cone is the part that looks like a cone.



Win.


But basically you've gotten all the info you need already. Nothing much more to say.
Where's Waldo?
#15
I doubt it's a speaker issue, if the speaker works through the external jack, then it works, if it's not working through the amps internal connection, then you have a internal amp problem on your speaker circuit.

EDIT: Nvm, disregard what I said.
Last edited by ethan_hanus at Sep 27, 2011,