#1
I own a Peavey VK 112 with 6L6 Vacuum tubes.
Lately the amp have started to make a crackling-like noise, and one of the tubes starts to slightly flash during the noise.
Do anyone know if i need to change the tube(s), or is there another solution?
#2
yea just change the tubes, two of the tubes in my VK100 just burnt out. Im going to have to wait to get some cash before putting new ones in. So im stuck playing my old line 6 now.

Epi LP Custom EMGs
ESP H-1000
Schecter Elite 7
Jackson Dominion
Peavey Valveking Head
Jet City JCA24s
Blackstar HT20 & HTV212
MXR Pedals
Schecter Stiletto Custom
Schecter Stiletto Studio
Fender Vintage Modified
Ampeg B2RE
Fender 4x10 Cab
#3
Yeah i guessed so, although i'm also short on cash but with no spare amplifier. I changed the tubes just a year ago, but i think that a cable was the cause of this short lifespan.
Anyway, thanks for the help.
#5
Yeah, i thought about trying that first. Got the suggestion of using electricity spray (dunno what it's called in english) in the sockets, so will give it a shot.
#6
Flashing and crackling is probably arcing. Very bad. I'd throw the tubes away and get a new set, and clean both sides of the tube sockets as well. Arcing across the power tubes can mess up an amp pretty badly.
#7
Quote by Roc8995
Flashing and crackling is probably arcing. Very bad. I'd throw the tubes away and get a new set, and clean both sides of the tube sockets as well. Arcing across the power tubes can mess up an amp pretty badly.

This.

And power tubes should always be replaced in matched pairs.
Hi, I'm Peter
#8
I guess that's probably for the best, to change the tubes. Thank you all for the help.