#1
That prob is...it ain't working ha. I put in my chain in front of my rig and stepped on it an nothing...i power it plus my pedals with the mxr power brick. I'd like to thinl its the port, but it lights up which, to me, indicates its getting power...anyone have an idea?
fender aerodyne jazz bass>mxr el grande bass fuzz>boss odb-3>dunlop crybaby bass wah>randall rba 500 es/ampeg 8x10
#2
does it make any noise or anything? If i remember right the mxr 10 band takes an 18v power adapter which means it might not be getting enough power. but im not sure how the power brick works.
My Gear:
Schecter Hellraiser FR Special.
EpiG400 lefty w/Dimarzio X2N/ Irongear Hot Slag
Peavey 6505+112 (head)
2x12 Cab w/ WGS v30 / gt65
GFS Tuner
TS-9 (Keeley ish mod)
Dunlop GCB-95 Wah truebypass
ICP Gstring Decimator
#3
Can you define "not working?"
I mean, is it cutting the signal? Is it just not making any difference to the tone whether on or off? Is it degrading the signal etc?
Only thing I can think of is, the MXR 10 band EQ uses 18V power, not the standard 9V. Powered with 9V will cause all lights to come on (albeit not that brightly) but will not work at its best. Try it with the power supply it comes with to double check it's not that.
So say what's wrong and we can go from there .
#4
Quote by drugfreeboy
That prob is...it ain't working ha. I put in my chain in front of my rig and stepped on it an nothing...i power it plus my pedals with the mxr power brick. I'd like to thinl its the port, but it lights up which, to me, indicates its getting power...anyone have an idea?

did you adjust the eq?
#5
It's an 18 volt pedal. Make sure you are using the right output on the brick.
If it doesn't work off the brick, try using the power supply that came with it.
#6
the power brick has 3 18v ports i plugged them into all three to no avail. when i step on the pedal no sound. signal is cut.
fender aerodyne jazz bass>mxr el grande bass fuzz>boss odb-3>dunlop crybaby bass wah>randall rba 500 es/ampeg 8x10
#7
Have you tried it with the included adaptor? And have you got any other 18V pedals that you can try the power brick with?
When you say signal is cut, what happens with the lights? FTR, when the pedal is off, the level and gain lights should be lit only. When the pedal is on, ALL lights should be lit. When the gain is so high that clipping occurs, the gain and level lights will flash, while the other 10 lights remain steady.
So, what happens with the lights, both when bypassed and when active?
Also, does moving any of the sliders do anything (both when bypassed AND active)?
#8
the lights come on when i step on it. just a dead signal. nothing. no sound from my guitar. i have the mids boosted for leads and i have the volume and gain up a bit to...but nothing that should make it clip.
fender aerodyne jazz bass>mxr el grande bass fuzz>boss odb-3>dunlop crybaby bass wah>randall rba 500 es/ampeg 8x10
#9
And I assume that the signal is fine when the pedal is in your chain, but bypassed?
Hmm... I really dont know. I think it might just be a problem with your pedal, in which case you'll just need to send it back and get it repaired.
It could only be one of two things:
1) A faulty power supply - but if you've tried the power brick AND the adaptor it came with, this seems highly unlikely
2) A faulty pedal.

How new is the pedal? If it's under warranty then i'd say just send it back .
#10
this may seem alittle obvious but do your other pedals work with the same power supply?
[Cool Post-N00b of the Pedalboard Thread]
Guitars:Fender Am. Standard Telecaster, Gibson SG
Amp:Fender Blues Jr.
Pedals:EQD Dream Crusher->Polytune->PH-1r->Fulldrive 2->Barber LTD->Catalinbread DLS->CE-3->Strymon El Capistan->EQD Ghost Echo
#11
Did you rule out a bad cable?
Does the signal reach the amp when the pedal is off?
#12
All my other pedals work with the power brick. Not a faulty chord. Yes the signal reaches the amp when off.
fender aerodyne jazz bass>mxr el grande bass fuzz>boss odb-3>dunlop crybaby bass wah>randall rba 500 es/ampeg 8x10
#14
It was working up until this week..i got no idea.
fender aerodyne jazz bass>mxr el grande bass fuzz>boss odb-3>dunlop crybaby bass wah>randall rba 500 es/ampeg 8x10
#15
How long have you had it? Get in touch with MXR's tech support. Maybe they will do a warranty swap.
#16
almost 2 years. i didn't get the warranty.
fender aerodyne jazz bass>mxr el grande bass fuzz>boss odb-3>dunlop crybaby bass wah>randall rba 500 es/ampeg 8x10
#17
Have it fixed

Mesa Royal Atlantic
Orange Rocker 15
Marshall Class 5C
Emperor 4x12 Silver Bells
Yamaha THR10
PRS Swamp Ash Limited Custom 24
LTD Viper 500 with Duncans