#1
I have a marshall MG15dfx and the fuse from the power supply burned/broke/or whatever it is that fuses do lol anyway it says t400ma 250v but i have only found t500ma 250v my question is can i use the 500 without it damaging the amp or do i need to get the 400 one?
I have checked radioshack, home depot n local electronics/hardware stores but havent found the 400 ones only 500
#2
No, you would need to get a 400ma fuse, otherwise you will damage the amp. It's either spend 50p on a fuse or paying a lot more for you amp to be fixed.
Quote by Kensai
You'll find whisky very different, but try it and you'll grow into it, soon you and whisky are one, but still two, lovers dancing across a frozen lake under moonlight, wrapped in honey and warmth.


Sums up whisky perfectly
#3
ok thanks. I already have some 500ma so if it was ok to use them i would have but since is not and i cant find the 400 in local stores im gonna order it online thanks for the help

the guy at the store said 500ma would be just fine but i wanted to double check before i went ahead n use it
Last edited by Geo.~ at Oct 25, 2011,
#4
The electronics of the amp (wires and such) can only pass so much current and if the current exceeds the rating of the fuse, the fuse will blow so that the flow of electricity is stopped avoiding damage to the amp. Now if you put a higher rated fuse in, the fuse will let a higher amount of current to pass, which the wires may not be able to handle, which will cause damage to the amp.

Also, you will want to buy slow blow fuses.
Quote by Kensai
You'll find whisky very different, but try it and you'll grow into it, soon you and whisky are one, but still two, lovers dancing across a frozen lake under moonlight, wrapped in honey and warmth.


Sums up whisky perfectly
Last edited by Archer18 at Oct 25, 2011,