#1
My crate BV60 half stack is not putting out sound. I turn it on, and the head seems to work fine but no sound comes out of the speaker cab at all. I don't know if I need a new speaker cable or if there's a different problem. I can hear the head "hum" when it's running like always, but no matter how long I give it to warm up there's still nothing coming out of the cab. Not even the usual hiss that it always makes either.
ESP/LTD F-50
1989 Kramer Showster
Rogue RADH Acoustic
Fender CD-60 Acoustic
Washburn XB-100 4 string
Peavey Millenium AC BXP
Fender Rumble 150
Crate BV60H Head
Crate BV412 Cab
Vox AD15VT
#2
Did you check the tubes? I know it's an obvious question, but I just wanna be sure.
Gear
Highway One Tele (w/Custom Shop 51 Nocaster pickups)
Standard Tele (modded to Nashville specs)
Reverend Roundhouse

Orange Rockerverb 50 MKI
Vox AC4c1
Jet City JCA20H

And pedals!



"Shiva opens her arms now..
...to make sure I don't get too far"
#3
How do I check the tubes? I mean, what do I look for to see if they're in good shape?
ESP/LTD F-50
1989 Kramer Showster
Rogue RADH Acoustic
Fender CD-60 Acoustic
Washburn XB-100 4 string
Peavey Millenium AC BXP
Fender Rumble 150
Crate BV60H Head
Crate BV412 Cab
Vox AD15VT
#4
Check your main fuse.


Does the main switch light up?

Does the standby light up?

Do the tube lights come on? (The lights behind the tubes, I am unsure if the BV60 has them)
#5
you should also check and see if a wire on the inside of the cab came loose(that happened to my peavey ms cab)
Schecter BlackJack Atx v-1fr
Ibanez Gax70l Duncan Distortions
Peavey XXX
Peavey MS 412
Marshall MA 412
EVH Wah
Ibanez TS-9
ISP Decimator
MXR Black Label Chorus
#6
The tube lights come on fine, the standby is lit up, main switch lights, all seems fine. I'll open up my cab and take a look.
ESP/LTD F-50
1989 Kramer Showster
Rogue RADH Acoustic
Fender CD-60 Acoustic
Washburn XB-100 4 string
Peavey Millenium AC BXP
Fender Rumble 150
Crate BV60H Head
Crate BV412 Cab
Vox AD15VT
#7
Okay, cab seems fine. All the connections are in place. So I guess I'll just try replacing the speaker cable and pray that it works then. (I don't have the cash for new tubes! haha)
ESP/LTD F-50
1989 Kramer Showster
Rogue RADH Acoustic
Fender CD-60 Acoustic
Washburn XB-100 4 string
Peavey Millenium AC BXP
Fender Rumble 150
Crate BV60H Head
Crate BV412 Cab
Vox AD15VT
#8
There are fuses for each power tube mounted to the chassis.

May be the tubes took a shit. If you change channels do you get anything?
#9
Still nothing on both channels. I opened her up and all the connections seem to be fine.
ESP/LTD F-50
1989 Kramer Showster
Rogue RADH Acoustic
Fender CD-60 Acoustic
Washburn XB-100 4 string
Peavey Millenium AC BXP
Fender Rumble 150
Crate BV60H Head
Crate BV412 Cab
Vox AD15VT
#11
You should always have spare tubes. You could have swapped them in and known if that was the problem by now if you did. You still haven't said if you checked the internal fuses. If they are blown it's almost certainly the power tubes.
Gilchrist custom
Yamaha SBG500
Telecasters
Randall RM100 & RM20
Marshall JTM45 clone
Marshall JCM900 4102 (modded)
Marshall 18W clone
Fender 5F1 Champ clone
Atomic Amplifire
Marshall 1960A
Boss GT-100


Cathbard Amplification
My band
#12
Okay, let it be said that I am no amp expert. I bought it used, and it hasn't been re-tubed by me. I don't know about fuses, I'll try and see if I can look at those.
ESP/LTD F-50
1989 Kramer Showster
Rogue RADH Acoustic
Fender CD-60 Acoustic
Washburn XB-100 4 string
Peavey Millenium AC BXP
Fender Rumble 150
Crate BV60H Head
Crate BV412 Cab
Vox AD15VT
#13
Quote by R45VT
How about the fuses???????????????????????????


seriously this. in the BV series of amps there are fuses for each set of tubes in addition to your main fuse. u can check them to see if they are bad but you will need a multi meter to get the definate judgement. not all fuses show burnt areas when they go bad. if you are not tech savvy just take it in.
Live Rig
Michael Kelly Custom Shop Plum Telecaster
Michael Kelly Custom Shop Plum Patriot


EVH 5153 50w
Jet City 2x12
Custom Board

It is NOT trash metal it is tHrash metal...get it right
#14
Be careful when you slide the chassis out. The filter caps can hold their charge for ages after switch off. If in doubt wear some gloves when poking around inside after the fuses. You'll already have pulled the chord out of the wall I'd assume.
Gilchrist custom
Yamaha SBG500
Telecasters
Randall RM100 & RM20
Marshall JTM45 clone
Marshall JCM900 4102 (modded)
Marshall 18W clone
Fender 5F1 Champ clone
Atomic Amplifire
Marshall 1960A
Boss GT-100


Cathbard Amplification
My band
#15
Ya know what? Screw it, she's going into a shop. haha
ESP/LTD F-50
1989 Kramer Showster
Rogue RADH Acoustic
Fender CD-60 Acoustic
Washburn XB-100 4 string
Peavey Millenium AC BXP
Fender Rumble 150
Crate BV60H Head
Crate BV412 Cab
Vox AD15VT