#1
I just bought the guitar to USB device
http://www.amazon.com/Behringer-UCG102-Guitar-to-USB-Interface/dp/B000PAPO9W

I have guitar rig 5 installed and it records just fine. However, I can't get real time sounds from my PC speakers. So what I mean is that the guitar rig 5 records the audio just fine. However, when I'm playing the guitar, I don't hear any sound in real time through my PC speakers.
Anyone familiar with Guitar rig can help me out? I use windows 7, and my PC is definitely powerful enough trust me on that (im a geek myself). Thanks!
#2
Are you using Guitar Rig in standalone or as a plugin?

I'm pretty certain this is because the output is being sent to the Headphone output on the Guitar Link instead of your computer's speakers. Are you using ASIO4ALL?
#3
Quote by kyle62
Are you using Guitar Rig in standalone or as a plugin?

I'm pretty certain this is because the output is being sent to the Headphone output on the Guitar Link instead of your computer's speakers. Are you using ASIO4ALL?


I think I'm using it as standalone because it's the only thing running. I'll link a screen shot for you guys to see

http://i2.photobucket.com/albums/y39/eatpumpkins/Untitled-396.jpg

I agree that the output might have been sent to the headphone output on guitar link, but how do I change it so the output is sent to computer speakers?

I think I installed some ASIO driver, but not sure. can you explain what ASIO4ALL is?
#4
you plug your speakers or headphones into the headphone output on the interface (it'll work with speakers too - just might need an adapter depending on your speakers) - that's usually how it works with interfaces - then in the Windows Sound control panel you can set all your windows functions to use that as your output too for regular Windows stuff, games, movies, etc.

I use a cheap set of headphones with all my different interfaces as they sound great - much better than most computer speakers. I actually bought a Y-Cord from Radio Shack and on my Mac I plug both speakers and Headphones into my Mac interface - on my Windows laptop I just use Headphones as laptop speakers suck anyways.
Now running an Eleven Rack with Pro Tools 10.3.3 - it's amazing and I'm having ball with it - worth every penny. PT 10 is tops IMO and the Eleven Rack is a work of art!
Last edited by strangedogs at Nov 30, 2011,
#5
With that particular interface there's a huge probability that you're going to experience serious latency when you're trying to play and/or record. I know, I've got one.
That's easily fixed though, you just go under "ASIO Config", and set the latency to Highspeed, which leaves it about 3ms
#7
Quote by strangedogs
you plug your speakers or headphones into the headphone output on the interface (it'll work with speakers too - just might need an adapter depending on your speakers) - that's usually how it works with interfaces - then in the Windows Sound control panel you can set all your windows functions to use that as your output too for regular Windows stuff, games, movies, etc.

I use a cheap set of headphones with all my different interfaces as they sound great - much better than most computer speakers. I actually bought a Y-Cord from Radio Shack and on my Mac I plug both speakers and Headphones into my Mac interface - on my Windows laptop I just use Headphones as laptop speakers suck anyways.


I would hate to go that set up but I guess I dont have many other options.

Quote by kyle62
Download and install ASIO4ALL: http://www.asio4all.com/


I DL'd and installed ASIO4ALL, now I cant even record things anymore.... Thanks a lot
#8
Buddy in the COMPUTER TECH SUPPORT world I used to belong to we called this:

P.I.C.N.I.C.

(problem in chair not in computer)

there are millions of people using ASIO4ALL successfully. You need to figure this out - it's your job to learn. Google, Read and experiment. This isn't hard - you'll figure it out - we did.
Now running an Eleven Rack with Pro Tools 10.3.3 - it's amazing and I'm having ball with it - worth every penny. PT 10 is tops IMO and the Eleven Rack is a work of art!
#9
I've been reading all night and I couldn't figure out what is going on. I just want some practical advice on how to do these things.

What I'm trying to do sounds very simple in theory, I just don't understand why these software are making it so complicated.

I'm sure many people have this set up, so any help is appreciated.
#11
Quote by icecoldstar
This is what I have right now

http://i2.photobucket.com/albums/y39/eatpumpkins/Untitled-492.jpg

Someone tell me what's wrong? Because now I get no sound out my PC speakers and recording doesn't work either.

Yes. Your Guitar Link isn't activated at all.

Ok, since I happen to have a similar setup to you, here's my ASIO panel in a VST amp sim:



Set it to the same settings and it will work. Basically you need your PC's soundcard output turned on (that's Realtek HD Audio Output') and the Guitar Link activated, but only as an input (that's 'BEHRINGER USB WDM AUDIO IN'.

I'd suggest starting with the buffer size at around 160, since this depends on the power of your PC.


Also, you may need to go into guitar rig's 'routing' tab to select the correct input and outputs.
#13
Quote by icecoldstar
I just bought the guitar to USB device
http://www.amazon.com/Behringer-UCG102-Guitar-to-USB-Interface/dp/B000PAPO9W

I have guitar rig 5 installed and it records just fine. However, I can't get real time sounds from my PC speakers. So what I mean is that the guitar rig 5 records the audio just fine. However, when I'm playing the guitar, I don't hear any sound in real time through my PC speakers.
Anyone familiar with Guitar rig can help me out? I use windows 7, and my PC is definitely powerful enough trust me on that (im a geek myself). Thanks!


http://www.amazon.com/Behringer-UCG102-Guitar-to-USB-Interface/dp/B000PAPO9W
Simple interface and amazing performance,records well and can be used with multiple
effects softwares.
Software supplied is gr8 too, cant believe all this for a low price.
Use it with my Bass and am quite satisfied!

#14
^ Ah, the Amazon shill/affiliate spam dude is back! He always backs me up when I use Amazon links

And icecold, got your PM but I can't be bothered with PMs usually - if you give advice in the forum, at least other people can read it if they get stuck. Took me bloody ages to figure out ASIO4ALL !
#15
If you just want to use guitar rig as an amp sim and you want to record some guitars.
You might as well download reaper.
Once you get asio set up right all you would have to do is arm a track and load guitar rig as an effect and turn monitoring on and you should be good to go.
That's what i used to do.
NEW SIGNATURE!
#16
Here is a pic of how I got everything set up, and still no sound, no recordings. Can someone tell me what is wrong here? and obviously I have all the drivers installed, cables plugged into the right places.



Quote by aeromakesmusic
If you just want to use guitar rig as an amp sim and you want to record some guitars.
You might as well download reaper.
Once you get asio set up right all you would have to do is arm a track and load guitar rig as an effect and turn monitoring on and you should be good to go.
That's what i used to do.


yes, that is all I want to do, but apparently if I dont have everything set up in guitar rig, there's no sound in reaper either.
Last edited by icecoldstar at Dec 3, 2011,
#17
Quote by icecoldstar
Here is a pic of how I got everything set up, and still no sound, no recordings. Can someone tell me what is wrong here? and obviously I have all the drivers installed, cables plugged into the right places.




yes, that is all I want to do, but apparently if I dont have everything set up in guitar rig, there's no sound in reaper either.


Yeah, I can see the problem. You've got the guitar link selected as an output instead of an input.

At the moment, Guitar Rig is trying to take sound from the line in on your PC, and output to the headphone jack on your guitar link. Disable the guitar link output and enable the input instead.
#18
Good call!
Now running an Eleven Rack with Pro Tools 10.3.3 - it's amazing and I'm having ball with it - worth every penny. PT 10 is tops IMO and the Eleven Rack is a work of art!
#20
sigh I tried to fix this piece of shit, this is what happened

i cant fking select the guitar link as the input source cuz it give me error message. how do i fix that? and yes i disabled system sounds and stuff

#21
Hey man, I know this is an old post but i just got the same problem. I can't access my guitar link In and got the same yello symbol (beyond logic). Did u solve the problem?