#1
Just got my 2555SL in, yay!!! Sorry for the bad pic, cant find my cameras usb cable.

Anyway, this technically isnt a NAD thread to review the amp, just a quick question since this is my first tube amp and all.

I just want to make sure I'm connecting it all correctly.

Its 16ohm on my both amp and cab on MONO. Is that correct?

Is there a particular speaker cable that works best with these tube amps, or are they all pretty much the same?

I'm waiting for the amp to warm up before I hook it up, just got out of a freezing truck and is like ice right now.



Uploaded with ImageShack.us
Last edited by pugachev at Dec 7, 2011,
#2
cool amp





HNAD



yes. 16 mono will be fine.

any speaker cable (no instrument cables) will be fine. there are better ones out there but I wouldn't worry about that right now. just get this ****er fired up
Last edited by 311ZOSOVHJH at Dec 7, 2011,
#3
HNGD!!!

Looks like a beast...

Yes, you want to hook it up Mono, 16 ohms...
I Play Guitar
Some Like it
Some don't
I don't care
Beats Workin'
OLD GUYS RULE!!!!
#4
Ok one more quick noob question

mains selection? Im in the US

I assume 110v like its already selected?
#5
yes on the mains.

agreed on the 16 mono.

damn nice rig, even if i'm not a huge slash fanboi.

congrats !
I wondered why the frisbee was getting bigger, then it hit me.
#6
you know i was surprised people telling me you cant get good tones out of these things at low volumes, so wrong. maybe not as good cranked sure, but this beats out any solid state amps i've played so far. hopefully clips to follow once I find the cable to my camera
#8
Quote by pugachev
you know i was surprised people telling me you cant get good tones out of these things at low volumes, so wrong. maybe not as good cranked sure, but this beats out any solid state amps i've played so far. hopefully clips to follow once I find the cable to my camera


who told you that?
Prs se Holcomb is the answer