#1
Hello all,
I'm just picking up guitar playing but I've had my Squier Strat for about 16 years. I haven't played it in about 8-10 years. I just got a new amp and plugged it in and all I'm getting is a buzzing sound.

I turned the volume up on each and the buzzing volume adjusts as I turn each knob. The buzzing also varies when I adjust the tone, bass, and gain knobs on both the guitar and amp.

But, I'm getting no actual 'guitar sounds.'

This sucks. I was so hyped to get back into this and now I feel like I've wasted money for nothing.

Anyone have any idea what's going on here? Can dust on the pickups cause this? The guitar had been packed away in a carrying case for the last 8-10 years and has some rust/gunk on different parts as well as a lot of dust buildup, but that's it.

Is my guitar broken? Is it the amp? What should I do?
#2
sounds like it needs the electronics cleaned with contact cleaner
2002 PRS CE22
2013 G&L ASAT Deluxe
2009 Epiphone G-400 (SH-4)
Marshall JCM2000 DSL100
Krank 1980 Jr 20watt
Krank Rev 4x12 (eminence V12)
GFS Greenie/Digitech Bad Monkey
Morley Bad Horsie 2
MXR Smart Gate
#3
If the amp makes loud buzzing noises when you touch the jack then the amp is probably ok. If not amp or lead is faulty. Suppect corroded jack socket or switch on guitar most likely spray in switch cleaner from Maplin (Radio Shack in US) and poke about with cotton bud.
#5
Thanks guys. I turned it off, gave it a few minutes and turned it back on.

After messing with the switches and knobs for a few minutes it finally started working when in "clean" mode. When I put it in "overdrive" mode it sounds like crap compared to how I remember it being when I used to mess with it.

Also, sometimes when I would flip the switch on the guitar by the knobs it would take a few minutes before the sound would come out on the amp. So, I'm wondering if maybe it just needed a few minutes to sort of burn the dust off?

You all think I still need to replace all of the stuff you mentioned above?

Also, I started to try to tune it and the string popped as I was tightening it... Guess it was time to replace them, lol.

Sorry for the lack of technical info in this post, but I'm really trying to get into playing, learning, and becoming proficient at this... today was certainly a bit of a let down though.
#6
Quote by Robbgnarly
sounds like it needs the electronics cleaned with contact cleaner


How would I go about doing that?
#7
you get some electrical contact cleaner. Spray it in the knobs housing where ever you cab get it in at. Then you trun the knobs back and forth. You then do the same for the switch.
the jack you spray it in the jack and plug your cable in and out.

You may have to do this a few times to get it working properly again. If not you may need to replace the pots,switch ect.
2002 PRS CE22
2013 G&L ASAT Deluxe
2009 Epiphone G-400 (SH-4)
Marshall JCM2000 DSL100
Krank 1980 Jr 20watt
Krank Rev 4x12 (eminence V12)
GFS Greenie/Digitech Bad Monkey
Morley Bad Horsie 2
MXR Smart Gate