#1
So i got a powered speaker last week its a kustom 100w 15in one, i got it because we have a unpowered mixer and needed a monitor, and im on a budget atm. But we where using it the other day and had an ipod plugged in and i was getting no response from the cone it seemed just from the horn, i dont know much about pas in general but that doesnt seem right to me. were only running vocals through the speaker right now and its loud enough to hear when we practice but still i feel like it shouldnt be just putting everything through just the horn. how do i fix it? should i just send it back and get a new one? or is there nothing wrong and im just trippin. lol
-Peavey 6505+
-Bugera 333xl(w/6l6 pt's) -dead
-412 X-pattern loaded w/ WGS veteran30s & HM75s
-Gibson Les Paul, SD Blackouts *being worked on back to stock*
-Jackson DR7, EMGs
-LTD MH417
-Peavey Vyper 75w
#2
When you say the cone do you mean the center of the speaker or are you reffering to a horn? If the speaker itself its probably fine. Remember its not going to move like a car subwoofer but should have some bass response. Is it not moving at all?
#3
it doesnt have any bass response, and i mean the woofer, i know its not like a car but i expected there to be some.
-Peavey 6505+
-Bugera 333xl(w/6l6 pt's) -dead
-412 X-pattern loaded w/ WGS veteran30s & HM75s
-Gibson Les Paul, SD Blackouts *being worked on back to stock*
-Jackson DR7, EMGs
-LTD MH417
-Peavey Vyper 75w
#6
so.. you're plugging the IPOD directly into the speaker, or into a channel in the mixer, then running it through the speaker?
I Play Guitar
Some Like it
Some don't
I don't care
Beats Workin'
OLD GUYS RULE!!!!
#7
into a channel into the mixer, and yeah it is that one.
-Peavey 6505+
-Bugera 333xl(w/6l6 pt's) -dead
-412 X-pattern loaded w/ WGS veteran30s & HM75s
-Gibson Les Paul, SD Blackouts *being worked on back to stock*
-Jackson DR7, EMGs
-LTD MH417
-Peavey Vyper 75w
#9
yeah i figured i just thought snice im playing an ipod through it that itd be putting out the bass from the song.
-Peavey 6505+
-Bugera 333xl(w/6l6 pt's) -dead
-412 X-pattern loaded w/ WGS veteran30s & HM75s
-Gibson Les Paul, SD Blackouts *being worked on back to stock*
-Jackson DR7, EMGs
-LTD MH417
-Peavey Vyper 75w
#11
lol yeah im not that retarded as retarded as my question is, yeah i am eqing everything, even with the bass turned all the way the ipod has no bass. the speaker is turned up 3/4 of the way, the mixer is about the same, i wanna say 0 db but dont quote me on it.

Ill go dick around with it more today, maybe get the drummer over and see if we cant some bass out of it.
-Peavey 6505+
-Bugera 333xl(w/6l6 pt's) -dead
-412 X-pattern loaded w/ WGS veteran30s & HM75s
-Gibson Les Paul, SD Blackouts *being worked on back to stock*
-Jackson DR7, EMGs
-LTD MH417
-Peavey Vyper 75w
#12
If you can hear it, then your levels are set high enough. If your bass EQ isn't at zero, you should hear bass... Sounds like maybe you have a bad speaker. Does it just sound tinny like you're only getting treble, or is the bass response just not as much as you expect?

Just read through last post again, and you say no bass... I'd return it if possible. A 100W powered speaker with a 15" woofer should give you a fair amount of bass. I play my iPod through my PA all the time, and I never have to change any settings
Quote by tubetime86
He's obviously pretty young, and I'd guess he's being raised by wolves, or at least humans with the intellectual capacity and compassion of wolves.


You finally made it home, draped in the flag that you fell for.
And so it goes
#13
The cone should definitely be visibly moving at high volumes. If your not sure put something in front of the m/h driver to block the sound, see if it sounds differently.

Could be a blown driver or a faulty connection to the speaker, check inside and see if everythings hooked up. If not return it.
#14
alright ill take a look at it and see what the hell is up tomorrow. thanks
-Peavey 6505+
-Bugera 333xl(w/6l6 pt's) -dead
-412 X-pattern loaded w/ WGS veteran30s & HM75s
-Gibson Les Paul, SD Blackouts *being worked on back to stock*
-Jackson DR7, EMGs
-LTD MH417
-Peavey Vyper 75w