#1
i was playing my ambient rig and wasn't satisfied with the OD i was getting from the board, i was running a MI audio Blues Pro into an OCD. it didn't work well. for a quick experiment, i plugged in the BBE green screamer and it wasn't working right and than was like oh shit. i had the OCD running at 18vdc and plugged that chord out of my pedal and into the BBE. bbe did not like the 18vdc.

so the pedal somehow works fine when engaged, but crackles when it is off and prior and after turning it on. i have no idea, took a quick peak at the board, nothing obvious.

now the amp: oddly this occured at the same time, lost all volume. the front end was getting hit pretty hard by the BLues pro and then the green screamer, and dropped a moderate volume down to nothing. turned up each channel's volume all the way and the master, just low quiet noise. i am pretty sure its the power tubes. not a terrible deal. i don't think i could have done anything to kill the amp.

so what do you all think? i am going to go for a pair of EL34's probably JJ because the previous tubes were a little shrill and slightly fizzy, i recon that will help with that. if you have a better suggestion than JJ's let me know. this is actually the only EL34 amp i have owned, other than the renegade.

so pedal fried?

bad tubes?
WTLT 2014 GG&A

Quote by andersondb7
alright "king of the guitar forum"


Quote by trashedlostfdup
nope i am "GOD of the guitar forum" i think that fits me better.


Quote by andersondb7
youre just being a jerk man.



****** NEW NEW NEW!
2017-07-07 2017-07-07 Update and a Chat On Noise Constraints *** NEW FRIDAY 7/7
2017-04-13 RUN AWAY from COMPUTERS!!! TCE? RANT ALERT!!!
2017-03-02 - Guitar Philosophy 1001- Be Prepared For the Situation (Thursday 2017-03-02)
2017-02-21 How to Hot-Rod the Hell of your Stratocaster for $50! (Tuesday 2017-2-21)
Resentments and Rambling from a Guitar Junkie
---> http://trashedengineering.blogspot.com/
Last edited by trashedlostfdup at Feb 4, 2012,
#2
Which amp? I don't think you mentioned.

JJ's should be fine. If you want to spend some extra cash on better tubes that are similar in tone look at some SED =C= or Russian NOS Mullards.

www.dougstubes.com
www.thevalvequeen.com

The pedal unfortunately may be fried.
#3
Quote by 311ZOSOVHJH
Russian NOS Mullards.(


what?

you mean the new russian mullards? the NOS ones were made in GB i think, they are great.

are the russian actually any good? i have tried a new mullard EL84 and 12AX7 and wasn't impressed at all, have they gotten better?
punk isn't dead, it's always smelled that way.

"A perfection of means, and confusion of aims, seems to be our main problem."
-ae
#4
Quote by 311ZOSOVHJH
Which amp? I don't think you mentioned.

JJ's should be fine. If you want to spend some extra cash on better tubes that are similar in tone look at some SED =C= or Russian NOS Mullards.

www.dougstubes.com
www.thevalvequeen.com

The pedal unfortunately may be fried.


trace elliot speed twin C50.
WTLT 2014 GG&A

Quote by andersondb7
alright "king of the guitar forum"


Quote by trashedlostfdup
nope i am "GOD of the guitar forum" i think that fits me better.


Quote by andersondb7
youre just being a jerk man.



****** NEW NEW NEW!
2017-07-07 2017-07-07 Update and a Chat On Noise Constraints *** NEW FRIDAY 7/7
2017-04-13 RUN AWAY from COMPUTERS!!! TCE? RANT ALERT!!!
2017-03-02 - Guitar Philosophy 1001- Be Prepared For the Situation (Thursday 2017-03-02)
2017-02-21 How to Hot-Rod the Hell of your Stratocaster for $50! (Tuesday 2017-2-21)
Resentments and Rambling from a Guitar Junkie
---> http://trashedengineering.blogspot.com/
#5
Quote by gumbilicious
what?

you mean the new russian mullards? the NOS ones were made in GB i think, they are great.

are the russian actually any good? i have tried a new mullard EL84 and 12AX7 and wasn't impressed at all, have they gotten better?

Honestly I don't remember, I just know they were Mullards and I liked them. I've heard they are similar to JJs. I've got SEDs now and honestly I can't tell if they are better or not.

Either way-sorry Derek
#6
the good: the tubes aren't bad, the effects loop volume must have gotten bumped and it cut signal with the effects loop turned on. so good, tiubes are fine atm.

i really do think that green screamer is dead. is there anyway i could fix it?
WTLT 2014 GG&A

Quote by andersondb7
alright "king of the guitar forum"


Quote by trashedlostfdup
nope i am "GOD of the guitar forum" i think that fits me better.


Quote by andersondb7
youre just being a jerk man.



****** NEW NEW NEW!
2017-07-07 2017-07-07 Update and a Chat On Noise Constraints *** NEW FRIDAY 7/7
2017-04-13 RUN AWAY from COMPUTERS!!! TCE? RANT ALERT!!!
2017-03-02 - Guitar Philosophy 1001- Be Prepared For the Situation (Thursday 2017-03-02)
2017-02-21 How to Hot-Rod the Hell of your Stratocaster for $50! (Tuesday 2017-2-21)
Resentments and Rambling from a Guitar Junkie
---> http://trashedengineering.blogspot.com/
#7
Quote by trashedlostfdup
the good: the tubes aren't bad, the effects loop volume must have gotten bumped and it cut signal with the effects loop turned on. so good, tiubes are fine atm.

i really do think that green screamer is dead. is there anyway i could fix it?


i remember a resister in the power supply that usually was the part that went on TS's. dunno about your pedal. i think cath knows the TS circuit fairly well, he might be able to offer help.

if you can handle a solder gun pretty well then you may be able to fix it for cheap.
punk isn't dead, it's always smelled that way.

"A perfection of means, and confusion of aims, seems to be our main problem."
-ae