#1
Hello all,

I was a little over zealous with my strat during a gig, I was digging in very hard for the end of one song. I actually cut my thumb, possibly on one of the middle pick up pole pieces!

Immediately after the song and everytime I let go of the strings I get near instant 'feedback'. This even happens with the amp (tried 2 amps) set clean and is magnified by any type of gain. Each string gives its own pitch if I mute them one by one but all produce feedback.

I mentioned I may have hit the middle pickup, could I have damaged it to cause this feedback? The guitar sounds fine while playing and the feedback happens on all 5 pickup selections - could the damaged pickup produce feedback even when not selected?

Any other ideas?

Thanks.
#2
No, if the pickup isn't selected it can't cause feedback. That means that your problem isn't with the pickup - not surprising, since it's tremendously difficult to damage a pickup.

More likely perhaps is that you yanked the pickup enough to pull out one or more of the ground connections. The first thing to do here would be to open the guitar up and re-do all of the connections, looking especially for solder joints or parts of the pickup selector that may have been damaged. I have to say I haven't heard of this exact problem, but I can't imagine what else it could be if not a broken ground connection.
#3
Quote by Roc8995
No, if the pickup isn't selected it can't cause feedback. That means that your problem isn't with the pickup - not surprising, since it's tremendously difficult to damage a pickup.

More likely perhaps is that you yanked the pickup enough to pull out one or more of the ground connections. The first thing to do here would be to open the guitar up and re-do all of the connections, looking especially for solder joints or parts of the pickup selector that may have been damaged. I have to say I haven't heard of this exact problem, but I can't imagine what else it could be if not a broken ground connection.



Was gonna post this, then read it, now quoting it. This.
OBEY THE MIGHTY SHITKICKER
#4
Problem solved: I tweaked every screw, found a slightly lose tone pot and set it up while I was at it. Seems something had worked its way loose.

Thanks for the replies.

I just need to stop trying to emulate Jonny Greenwood on stage