#1
Hey guys. A few weeks ago, my amp had a loud humming issue, so I checked everywhere online and could not find a forum with a fix for this. So I reluctantly dropped my amp off at a peavey authorized tech and 4 weeks later.....longest wait ever!.....it turns out it was just the phase inverter tube!!!
So I guess my purpose for this thread is, if you have this issue, check the phase inverter tube, as its unbelievably easy to fix yourself, before bringing it in. Good luck
#2
thanks for the heads-up- maybe post this in the 5150/6505 thread where it's of most use? if the TS is still around he could put it in one of the first posts
I'm an idiot and I accidentally clicked the "Remove all subscriptions" button. If it seems like I'm ignoring you, I'm not, I'm just no longer subscribed to the thread. If you quote me or do the @user thing at me, hopefully it'll notify me through my notifications and I'll get back to you.
Quote by K33nbl4d3
I'll have to put the Classic T models on my to-try list. Shame the finish options there are Anachronism Gold, Nuclear Waste and Aged Clown, because in principle the plaintop is right up my alley.

Quote by K33nbl4d3
Presumably because the CCF (Combined Corksniffing Forces) of MLP and Gibson forums would rise up against them, plunging the land into war.

Quote by T00DEEPBLUE
Et tu, br00tz?
#5
I'm an idiot and I accidentally clicked the "Remove all subscriptions" button. If it seems like I'm ignoring you, I'm not, I'm just no longer subscribed to the thread. If you quote me or do the @user thing at me, hopefully it'll notify me through my notifications and I'll get back to you.
Quote by K33nbl4d3
I'll have to put the Classic T models on my to-try list. Shame the finish options there are Anachronism Gold, Nuclear Waste and Aged Clown, because in principle the plaintop is right up my alley.

Quote by K33nbl4d3
Presumably because the CCF (Combined Corksniffing Forces) of MLP and Gibson forums would rise up against them, plunging the land into war.

Quote by T00DEEPBLUE
Et tu, br00tz?