#1
So I have a Peavey TNT 130 bass amp and it's been absolutely perfect until yesterday. When I try to play through it, it sounds distorted and weak (pretty much exactly how it sounds when a bass' battery is dying.) The thing is, I've tried it with both my basses and 2 different cables. All of which work perfectly, so I know it's the amp. I haven't done anything lately that would make this suddenly happen that I know of so I would really appreciate y'all's help. Thank you in advance!

inb4 what I really need is a new amp
For how can I give the King his place of worth above all else
when I spend my time striving to place the crown upon myself?
#2
I hate to bump this, but I could really use some help here.
For how can I give the King his place of worth above all else
when I spend my time striving to place the crown upon myself?
#4
It's not.
For how can I give the King his place of worth above all else
when I spend my time striving to place the crown upon myself?
#5
Hmm. Well it sounds like you should take it to a tech. Do you have any near you?
#6
Unless it's something as simple as one of the input jacks being faulty (which doesn't seem to be the case) then you are likely going to need a new amp. Take it to a tech to be sure, and figure out if it's salvageable.
Quote by SG_dave at #33549256
I've never wanted to see a guy eat dick so much in my life.
Quote by ali.guitarkid7 at #33553650
If you are white, you are scum.
#7
Don't have the money to take it anywhere. Just spent $600 on a new computer. Thanks anyways guys.
For how can I give the King his place of worth above all else
when I spend my time striving to place the crown upon myself?
#8
Clean the sockets before getting too excited. Get some contact cleaner and use a plug (like a guitar cable) as an applicator. All sockets, ins and outs.
Always try simply cleaning things, you'd be amazed how many faults are fixed that way - not that the shop will ever tell you.
"Yes sir, it required a new flux capacitor. That will be $300."
Gilchrist custom
Yamaha SBG500
Telecasters
Randall RM100 & RM20
Marshall JTM45 clone
Marshall JCM900 4102 (modded)
Marshall 18W clone
Fender 5F1 Champ clone
Atomic Amplifire
Marshall 1960A
Boss GT-100


Cathbard Amplification
My band
#9
Alright thank you. You're suggesting I put some of it onto a cable and put the cable into my input slots?
For how can I give the King his place of worth above all else
when I spend my time striving to place the crown upon myself?
#10
Yup. Definitely couldn't hurt to try. What kind of PC did you get?
Quote by SG_dave at #33549256
I've never wanted to see a guy eat dick so much in my life.
Quote by ali.guitarkid7 at #33553650
If you are white, you are scum.
#11
Custom built it. Basic specs:
Gigabyte GA990XAUD3 mobo
AMD FX4100 processor
8gb ram (G Skill ripjaws)
Powercolor Radeon 6790 videocard

Anyway, thank you gentlemen for the help! Hopefully this will work.
For how can I give the King his place of worth above all else
when I spend my time striving to place the crown upon myself?
#12
Yeah just spray a heap on the plug on the end of your cable and then work it in and out of the socket a few times. It will clean both plug and jack.
Gilchrist custom
Yamaha SBG500
Telecasters
Randall RM100 & RM20
Marshall JTM45 clone
Marshall JCM900 4102 (modded)
Marshall 18W clone
Fender 5F1 Champ clone
Atomic Amplifire
Marshall 1960A
Boss GT-100


Cathbard Amplification
My band
#13
Quote by Rawshik
Custom built it. Basic specs:
Gigabyte GA990XAUD3 mobo
AMD FX4100 processor
8gb ram (G Skill ripjaws)
Powercolor Radeon 6790 videocard

Anyway, thank you gentlemen for the help! Hopefully this will work.



I recently got a new PC in November, though it was a pre-built dell with a quadcore i5. Threw in a 2GB GTX 560 and more RAM than necessary, rolling with Skyrim on Ultra

Hope you can sort out your amp troubles.
Quote by SG_dave at #33549256
I've never wanted to see a guy eat dick so much in my life.
Quote by ali.guitarkid7 at #33553650
If you are white, you are scum.
#15
Quote by CL/\SH


I recently got a new PC in November, though it was a pre-built dell with a quadcore i5. Threw in a 2GB GTX 560 and more RAM than necessary, rolling with Skyrim on Ultra



Nice! The rest of us got laid.
Tastes like chicken, if chicken was a candy.
#16
This thread isn't about computers and no one cares about your sex life which probably doesn't actually exist.

Okay, so I went to Walmart and this was the only stuff I could find: http://www.amazon.com/CRC-05101-QD-Electronic-Cleaner/dp/B000CCMLD0

Will that work?
For how can I give the King his place of worth above all else
when I spend my time striving to place the crown upon myself?
#17
Also, I have a scratchy pot on my bass, will that stuff work for that too? I need a quick reply, thank you.
For how can I give the King his place of worth above all else
when I spend my time striving to place the crown upon myself?
#18
Quote by Rawshik
Also, I have a scratchy pot on my bass, will that stuff work for that too? I need a quick reply, thank you.



Yep, CRC makes good stuff.

While it should be fine, test to make sure it doesn't trash your finish...
“Ignorance more frequently begets confidence than does knowledge.”
Charles Darwin
#19
Quote by ConfederateAxe
Nice! The rest of us got laid.


/envy
Gear:
ESP LTD Les Paul (Blackouts)
B.C. Rich Mockingbird (EMG 81/85)
Paul Reed Smith SE Single-Cut (Duncan Pickups)
Schecter C-1 Classic (Duncan Pickups)
Epiphone Les Paul
Seagull Entourage (Acoustic-Electric)

Marshall JVM210H + 1960A Cab
#20
So I messaged the nearest amp repair place around here and they said this, "Sounds like it could be transistors or filter caps. Typically in the $125 to $150 range."

Anyone have any thoughts on that? Anyone know what those are/if they are easy to fix and if that's how much they would actually cost to repair? I mean, cause I could go on craigslist and find a used half stack for that much.
For how can I give the King his place of worth above all else
when I spend my time striving to place the crown upon myself?
#21
Anyone have any insight?
For how can I give the King his place of worth above all else
when I spend my time striving to place the crown upon myself?
#22
It could quite easily be the output transistors, or even possibly the power supply caps. What they did was quote you pretty much the most expensive possibilities. Did you try cleaning it like I suggested? You should always try cleaning things first, it's the most common cause of faults and the easiest thing to do. It isn't uncommon for shops to say they replaced an expensive part when all they actually did was clean it.
Gilchrist custom
Yamaha SBG500
Telecasters
Randall RM100 & RM20
Marshall JTM45 clone
Marshall JCM900 4102 (modded)
Marshall 18W clone
Fender 5F1 Champ clone
Atomic Amplifire
Marshall 1960A
Boss GT-100


Cathbard Amplification
My band
#23
I did exactly as you directed and no dice. Should I try more? Doesn't seem to be the problem with it if both inputs produce the same problem.
For how can I give the King his place of worth above all else
when I spend my time striving to place the crown upon myself?