hi all,

i've been having trouble with my tele for a while, honestly not sure if it's a faulty pick up or what..

i'm playing through a blues junior (jensen c12 speaker), and it seems no matter what i do the bridge pick up sounds far too harsh/brittle..

i've found that if i chain it with my boss monte sd1, it acts as a kind of buffer, reducing the shrill-ness?

i don't really like using pedals in the chain, especially when it's only there to buffer!

i've listened to many many demos on youtube of a tele bridge pick up through a BJ, it shouldn't sound as horrid as mine!

anybody have experience with this?
Turn the amp's treble down, that should take care of it.
Fender American Special HSS Stratocaster
Ibanez 1987 Roadstar II Deluxe
Yamaha THR10X
Marshall JCM900 SL-X
Ibanez WD-7 Weeping Demon Wah
TC Electronic Polytune
Seymour Duncan Tweakfuzz
ive got the treble on the amp rolled back, so EQ looks like..
bass: 6 or 7/10
mids: 5/10
treble: 4/10

should it not be possible to play a tele straight up through a clean amp on bridge without sounding ice-pick harsh?
a tele should definitely sound bright, but not painfully so. Have you tried engaging the "fat" switch on your amp?

also, I found that jensen speaker to be tremendously bright. If you have a chance, try plugging the amp into a cab loaded with a celestion V30 or something similar.

Tele's are very bright. Often, I've found that they sound too bright when you're playing without a band (I play a tele through a Fender), but they cut really nicely when you add more instruments to the mix. I found, however, that using a slightly darker sounding string (like DR instead of EB or D'addario) can help to tame the brightness just a little bit.
Don't sweat the petty things and don't pet the sweaty things...