#1
Right, this isn't the usual what pedal goes where thread, something a bit different.

Basically, my amp has an effects loop that is supposed to be switchable, and it controls the reverb too. When I turn the reverb up with no pedals in the loop, it'll go from off to on as I please. However, when I introduce pedals to the loop, the reverb still goes off but the effect from the pedal still remains.

Just wondering if this is a fault, or if it's meant to be like this? Thanks!
PRS SE Torero | Fender MIM Tele | Jackson RR3

Bugera TriRec Infinium | Randall RH50T

Marshall 1960AV

Soundcloud
Band Facebook
#4
Right! Well I've got a valveking & on the foot switch I have two buttons. One called Channel/Loop & one called Boost.

Although it's called Channel/Loop it only changes the channel & not the effects loop. I've heard it because it can engage the effects loop on other peavey amps.

Maybe this is the case with your Randall?
#5
on my footswitch, there's channel, gain to switch between the 2 gain modes on the OD channel, clean boost for the clean channel, and FX/Reverb to switch the reverb and effects loop
PRS SE Torero | Fender MIM Tele | Jackson RR3

Bugera TriRec Infinium | Randall RH50T

Marshall 1960AV

Soundcloud
Band Facebook
#6
Maybe the pedal only turns on/off the reverb on your amp & not the effects loop.

Does it work with the reverb off?
#7
everything works fine, it's just the effects loop never seems to close whenever i press the footswitch, and loop/reverb is always on if the footswitch isn't plugged in
PRS SE Torero | Fender MIM Tele | Jackson RR3

Bugera TriRec Infinium | Randall RH50T

Marshall 1960AV

Soundcloud
Band Facebook
#8
I wonder if the footswitch is just a generic randall footswitch. Like it changes the reverb or the loop depending on what the amp features are. I think, for your amp, it just changes the reverb on and off. The loop will always be active if you have pedals plugged into it.