#1
Hey,
So I was playing my amp just fine a few days ago and it worked perfectly fine, but I go to turn it on the next day and it turns on but the tubes won't even light up. I've diagnosed it in just the head because I narrowed it down using different heads, guitar cables, cabs, guitars, and amp cables. It turns on and won't produce sound. I noticed it got quite hot when I played it a couple days before and thought maybe some sort of fuse went out but wouldn't it have blown while I was playing? I would really appreciate help! I just want my baby back to normal! Thanks.

- Joe
#2
Joe,

Is this the JVM? Did you check the HT fuse? If it powers up When switched on then its not the main fuse. Also there maybe heater fuses internally.
#3
Yeah it's the JVM. I haven't checked anything internally yet because I'm nervous I'll just screw it up majorly. But I do have background knowledge or electrical systems and stuff front my automotive knowledge.
#5
Alright, but how do I get to the electronics? Take off back grille, grab the board and flip it and carefully put it somewhere?
#6
Quote by lightningjoe88
Alright, but how do I get to the electronics? Take off back grille, grab the board and flip it and carefully put it somewhere?

Basically. Yes.

Be careful not to touch anything on the inside. The High Tension fuses should be close to the power supply which will be the big transformer near the where the power cord goes in.

Inspect those fuses.

Yes, find a safe place to flip it onto before you start you are fumbling with a heavy chassis.

If your amp is like mine then there will 4 screws on the bottom of the headshell that bolt the chassis down.

Edit: I think. I'm not a tech.


This may help a bit:
http://profile.ultimate-guitar.com/311ZOSOVHJH/blog/80083/
#7
Awesome. I'm going to inspect it first and if I know I don't wanna take a chance then I'll hand it over to a tech... if I can find one. Thanks
#10
RadioShack or any other small electronics store
2002 PRS CE22
2013 G&L ASAT Deluxe
2009 Epiphone G-400 (SH-4)
Marshall JCM2000 DSL100
Krank 1980 Jr 20watt
Krank Rev 4x12 (eminence V12)
GFS Greenie/Digitech Bad Monkey
Morley Bad Horsie 2
MXR Smart Gate
#11
Quote by Robbgnarly
RadioShack or any other small electronics store


RadioShack has a pretty good selection of fuses.

TS- keep in mind fuses blow for a reason. A tube replacement may in order...

If you know automotive then you can probably bias it yourself. Most newer Marshall's have bias pins for you to check just a few volts. I'm not sure on the JVM.

I'm on my phone now, maybe later I can try to dig that up.
#12
Alright, I checked it out and it looks like there may be a bad fuse but I took a few pictures for some help. I'll post them tomorrow probably after work. Thanks