jeleopard
Jackson Fanboy!
Join date: Apr 2011
170 IQ
#1
So I recently bought a Peavey 6505+ and I'm trying the get the tubes in. For the power tubes, do I need to screw in the metal ring? I can't get the screws to actually go in :\
Legion!
Original 1969 Fender Jazzmaster
Ibanez RG8
Jackson JS32R Dinky "Curry"
Schecter KM7
83 Gibson Explorer "Kimmy"
MiM Fender Jazz Bass "Pancho"
Ibanez SR485
Peavey 6505+ 112
Line 6 POD HD500
R45VT
Doesn't speak guitar
Join date: Dec 2009
110 IQ
#3
What? There should have been nothing to unscrew.

Basically you pull apart the clips and pull them out, the to install you spread them open and install the new tubes, being carefull to clock them properly with the alignment tab.

I am assuming you have the back cover off?
cdr_salamander
or simply Nick
Join date: Mar 2009
90 IQ
#5
What? There should have been nothing to unscrew.
Quote by Dunning~Kruger
Yes I was rude, and I was aggressive and I was offending a large group of people. But I was civlized about it.

Taylor 414CE
jeleopard
Jackson Fanboy!
Join date: Apr 2011
170 IQ
#6
Hurrhurr.

I got it, it was the clip to the power tubes, it was unscrewed, and I was trying to screw it on with the power tube in it.

Now then, when I turn the amp on, it sounds like wind coming through the speaker. What do?
Legion!
Original 1969 Fender Jazzmaster
Ibanez RG8
Jackson JS32R Dinky "Curry"
Schecter KM7
83 Gibson Explorer "Kimmy"
MiM Fender Jazz Bass "Pancho"
Ibanez SR485
Peavey 6505+ 112
Line 6 POD HD500
R45VT
Doesn't speak guitar
Join date: Dec 2009
110 IQ
#7
Quote by jeleopard
Hurrhurr.

I got it, it was the clip to the power tubes, it was unscrewed, and I was trying to screw it on with the power tube in it.

Now then, when I turn the amp on, it sounds like wind coming through the speaker. What do?


Yeah that's bad...

Are they glowing red?


Why are you replacing them?
jeleopard
Jackson Fanboy!
Join date: Apr 2011
170 IQ
#9
Quote by R45VT
Yeah that's bad...

Are they glowing red?


Why are you replacing them?


They were shipped out of the amp. I'm putting them in.
Legion!
Original 1969 Fender Jazzmaster
Ibanez RG8
Jackson JS32R Dinky "Curry"
Schecter KM7
83 Gibson Explorer "Kimmy"
MiM Fender Jazz Bass "Pancho"
Ibanez SR485
Peavey 6505+ 112
Line 6 POD HD500
R45VT
Doesn't speak guitar
Join date: Dec 2009
110 IQ
#10
Quote by jeleopard
They were shipped out of the amp. I'm putting them in.


Whom did you buy it from?

Are they glowing red?

Do you have the pre amp tubes installed?
NotTheMessiah30
UG Fanatic
Join date: Sep 2012
70 IQ
#11
If by wind you mean a general kind of hiss then that's normal. The 6505(+) is a noisy amp, and there isn't really anything you can do to change that.

On the other hand if that noise is all you're getting then clearly something is wrong.
Cathbard
Grumpy Old Tech
Join date: Oct 2009
240 IQ
#12
Combo or head?
Gilchrist custom
Yamaha SBG500
Telecasters
Randall RM100 & RM20
Marshall JTM45 clone
Marshall JCM900 4102 (modded)
Marshall 18W clone
Fender 5F1 Champ clone
Atomic Amplifire
Marshall 1960A
Boss GT-100


Cathbard Amplification
My band
Tremolo Bum
Addicted to FR
Join date: Feb 2008
130 IQ
#13
If you are using a lot of gain there will be some hiss. Especially with this amp. However, if it is completely excessive, there might be something wrong. Do you have everything plugged in with your guitar? What channel and settings are you using?

We need a bit more info here.

Jackson RR3 Rhoads and DK2M Dinky
Peavey 6505+ w/ Avatar 212 cab
Ibanez TS9, ISP Decimator, MXR 10 Band EQ
-Digitech RP1000