#1
I just tried connecting the power supply to my POD...and the screen is not turning on nor is the green light on the adapter.

I have the adapter plugged into the wall. Will there be a green light on it if its plugged into the wall but not the POD? Or does the green light only come on when the adapter is connected to the POD? I cannot remember. Trying to determine is the issue is the adapter vs the unit.

Thanks in advance
#3
The green light only comes on when it's plugged into the POD. As for fixing it, I've no idea. I've heard quite a few complaints of people having problems with the power jack, mine feels a bit flimsy. I can see how it could break pretty easily.
#4
do you have the 'factory' power supply? if not make sure you are running the right voltage in, i am assuming (maybe incorrectly) that you may not be from the US (spelling or flavour in title is a little.

if you don't have the factory power supply, are you running the proper adapter for your country's power?
WTLT 2014 GG&A

Quote by andersondb7
alright "king of the guitar forum"


Quote by trashedlostfdup
nope i am "GOD of the guitar forum" i think that fits me better.


Quote by andersondb7
youre just being a jerk man.



****** NEW NEW NEW!
2017-07-07 2017-07-07 Update and a Chat On Noise Constraints *** NEW FRIDAY 7/7
2017-04-13 RUN AWAY from COMPUTERS!!! TCE? RANT ALERT!!!
2017-03-02 - Guitar Philosophy 1001- Be Prepared For the Situation (Thursday 2017-03-02)
2017-02-21 How to Hot-Rod the Hell of your Stratocaster for $50! (Tuesday 2017-2-21)
Resentments and Rambling from a Guitar Junkie
---> http://trashedengineering.blogspot.com/