#1
Had this amp for about 2 years now, been perfect for the most part. However, when the band split up it went to my drummer for a while; he didn't use it. I got it back a few weeks out, still works perfectly, however yesterday morning I turned it on and it wasn't as "loud" as usual.
Normally I can edge the Master Volume up and it's fine, however now even when I have the master volume at 0 I can still hear me amped playing very quietly, I edge it up, it doesn't change in volume, and at about only 2 does it get louder and turns into a lesser version of the tone it once was.

No other setting have been changed.

It still "works" but it sounds as if the tone is being throttled, I have to have it at a much higher Master Volume to achieve the loudness I'd practice at, and the "still hearing it at 0 Master Volume when I normally shouldn't" I think is strange.

Any advice?
#2
get new tubes
2002 PRS CE22
2013 G&L ASAT Deluxe
2009 Epiphone G-400 (SH-4)
Marshall JCM2000 DSL100
Krank 1980 Jr 20watt
Krank Rev 4x12 (eminence V12)
GFS Greenie/Digitech Bad Monkey
Morley Bad Horsie 2
MXR Smart Gate
#4
This happened to me once, and, whilst I'm not saying it's the same cause and solution, it was because the master knob wasn't gripping properly on the actual knob that connects to the control. this meant that whilst the knob was being pushed, the volume wasn't increasing as it should. Probably not the same situation but ah well
#5
Quote by Foxbite
Are you sure this is definately the problem?


Tubes are the only thing you can service yourself on that amp. Past that it needs to go to a repair shop.

Tubes do not last forever.

Replace them and retest it. If you still have the same problem take it in for diagnostic.

You are not paying him for his advice, he will not guarantee to tube will fix it. It does fit with the symptoms of bad tubes.
Quote by DeathByDestroyr
See, it's important that people clarify when they say "metal", because I pretty much always assume they are a Cannibal Corpse fanboi.
#6
Quote by Foxbite
Are you sure this is definately the problem?

Without having the amp in front of me I can not be 100%

But the amp is 2 yrs old and the problems you are having are most often tube related.
So that is my best logical guess
2002 PRS CE22
2013 G&L ASAT Deluxe
2009 Epiphone G-400 (SH-4)
Marshall JCM2000 DSL100
Krank 1980 Jr 20watt
Krank Rev 4x12 (eminence V12)
GFS Greenie/Digitech Bad Monkey
Morley Bad Horsie 2
MXR Smart Gate