#1
I recently bought a USB audio interface, and the line inputs cannot get to the DAW...
i.e. I can monitor them, but cannot record them.
The company which made the interface told me that this is a bug.

If this bug can't be fixed by new drivers or patches, I am thinking of getting a refund.

What do you guys think? Usually how are these bugs fixed? Or should I just go for the refund...
#2
I'd go right for the refund and get another machine. I've never heard of something like that, and I would not stick with a company that shipped that out (knowing it was a bug).

I got a broken mic in the mail once, broken pieces bouncing around directly below the QC slip. I returned it and bought from another company, because I don't want to support a company whose QC is that sketchy. (Blue Bluebird)

What interface is it, by the way?
Telecaster - SG - Jaguar
Princeton Reverb, Extra Reverb
P-Bass - Mustang Bass
Apogee Duet 2 - Ableton Suite
#3
scarlett 18i8

yea, it's probably the QC's problem, it seems to the me that they just found out about the bug when I told them...

for 4 XLR combo inputs it's really cheap.... don't want to buy expensive ones like roland's
#4
That's very strange for a Focusrite. Did they say it was a bug in everything across the product line, or just the specific unit that you have? This is a situation where you could try buying a different unit haha
Telecaster - SG - Jaguar
Princeton Reverb, Extra Reverb
P-Bass - Mustang Bass
Apogee Duet 2 - Ableton Suite
#5
although i think the support guy implies that.... he didnt say that
yea, i'm thinking about buying another unit too, coz asking for a refund here in Hong Kong might not be that easy....
#6
That is really strange as Focusrite is known for having quality budget units and to also see problems with a unit that just hit the market a month ago. Does your DAW show all 8 inputs from the 4 XLR inputs & 4 Line in inputs? Also, what DAW are you using?

I'd say contact Focusrite support again. Their support is really good (one of them hangs around here) and if they can't help you fix it, they'll probably replace it under warranty.
Derpy Derp Derp Herp Derp
#7
Quote by jszy
scarlett 18i8

yea, it's probably the QC's problem, it seems to the me that they just found out about the bug when I told them...

for 4 XLR combo inputs it's really cheap.... don't want to buy expensive ones like roland's

If you want 4 combo inputs on a budget, the Akai EIE Pro is half the price of the Focusrite, it's a good bit of kit. Or grab a Tascam US1800, which gives you £8 inputs for £220ish.
#8
Quote by lockwolf
Their support is really good (one of them hangs around here)


Who's that?

CT
Could I get some more talent in the monitors, please?

I know it sounds crazy, but try to learn to inhale your voice. www.thebelcantotechnique.com

Chris is the king of relating music things to other objects in real life.
#9
Quote by lockwolf
That is really strange as Focusrite is known for having quality budget units and to also see problems with a unit that just hit the market a month ago. Does your DAW show all 8 inputs from the 4 XLR inputs & 4 Line in inputs? Also, what DAW are you using?

I'd say contact Focusrite support again. Their support is really good (one of them hangs around here) and if they can't help you fix it, they'll probably replace it under warranty.


i must agree with you that their support is really good, very helpful, very easy to contact, doesnt have a telephone maze

i am using ableton live lite 8, but i have tried Live 9, Reaper, and adobe audition, on both Windows 7 and Windows XP

DAW shows all the inputs i have, but again, my mixcontrol direct monitoring gives me signals, so i hear it with the headphone, but no signal in DAW, and no signal at the fader corresponding to DAW in the mixcontrol


Do you think I can get a replacement in Hong Kong? There are only distributors for Focusrite, but not the company itself...
#10
Quote by axemanchris
Who's that?

CT


neil_focusrite or something like that. I've seen him post a few times when people have posted about issues with Focusrite interfaces.

Do you think I can get a replacement in Hong Kong? There are only distributors for Focusrite, but not the company itself...


Give it a shot. Its under warranty still. Still, if its showing up in MixControl, it sounds more like a DAW issue than an interface issue.
Derpy Derp Derp Herp Derp
#11
Wait when you say you can monitor, do you mean you can use direct monitoring or monitoring from in your DAW? If it's inside your DAW then it's most likely a problem with your DAW, because that means your DAW is getting the input and refusing to actually record it.
If it's the direct monitoring then I would guess that something else is using your audio device and preventing your DAW from using them. If you're on windows check your audio devices and make sure it's not the default device, and that nothing is using it. If it is, set something else as default, unplug it (this will force all other applications to the default device) then plug it back in and select it as your device in your DAW.
#12
Quote by chatterbox272
Wait when you say you can monitor, do you mean you can use direct monitoring or monitoring from in your DAW? If it's inside your DAW then it's most likely a problem with your DAW, because that means your DAW is getting the input and refusing to actually record it.
If it's the direct monitoring then I would guess that something else is using your audio device and preventing your DAW from using them. If you're on windows check your audio devices and make sure it's not the default device, and that nothing is using it. If it is, set something else as default, unplug it (this will force all other applications to the default device) then plug it back in and select it as your device in your DAW.


Again, no signal from DAW, i can only monitor with direct monitoring.

But what you say is starting to make sense to me, maybe it's the problem with default audio device. Because when I make a call on skype and open ableton live during the call, the person i am calling cannot hear me. Does this have anything to do with default audio device?

however, once again, don't you find it strange that when I plugged in both mic and guitar, I can record mic but not guitar? (with correct choices of inputs in DAW)
#13
here's an update to the problem, i was told that the scarlett 18i8 works on protools, but not on ableton live (which comes with the interface...), reaper or adobe audition...

any thoughts on this?

(by "works", i mean the line input can be recorded)
#14
Have you tried my solution yet? it really does sound like the inputs are being used by something else and so you can't use them in ASIO.
#15
Quote by chatterbox272
Have you tried my solution yet? it really does sound like the inputs are being used by something else and so you can't use them in ASIO.


well i havent got the chance yet, i took the interface back to the company for a check

will try out your method tomorrow, thank you
#16
Quote by jszy
here's an update to the problem, i was told that the scarlett 18i8 works on protools, but not on ableton live (which comes with the interface...), reaper or adobe audition...

Yeah, that's a load of rubbish.
#17
I feel more like its not something setup right in each DAW versus an actual interface issue, especially if it works in Pro Tools. From experience, Pro Tools doesn't play well with interfaces that aren't MBoxes or by M-Audio.
Derpy Derp Derp Herp Derp
#18
Tried changing the default audio device, no luck.

Quote by lockwolf
I feel more like its not something setup right in each DAW versus an actual interface issue, especially if it works in Pro Tools. From experience, Pro Tools doesn't play well with interfaces that aren't MBoxes or by M-Audio.


Well, I told Focusrite I can't record the line input 5, and they replied me that line 5-8 are not recognized by Ableton. It looks like they have tested it and realize the problem is with the firmware.
#20
Neil, this is why we love having you here
Derpy Derp Derp Herp Derp
#21
Quote by Neil_Focusrite
Hi Jszy,

We have just released an update that fixes this issue:

http://uk.focusrite.com/downloads/scarlett-mixcontrol-15

Please follow the steps detailed in the release notes. Apologies for the inconvenience caused by this problem. Let me know how you get on with the update.

Best regards,

Neil Marron
Focusrite Technical Support


yup it works now, thanks!
#22
Quote by lockwolf
Neil, this is why we love having you here


Yes, kudos to you, Neil!

CT
Could I get some more talent in the monitors, please?

I know it sounds crazy, but try to learn to inhale your voice. www.thebelcantotechnique.com

Chris is the king of relating music things to other objects in real life.