#1
I hope this is the right section

So I just got a new macbook pro and I previously was using an asus laptop with reaper and my tascam us-122mkII for 2 years.

Reaper on the pc works perfectly and I never had any problems. Same with the interface.

Now I've setup my interface on my mac and it works perfectly with everything, I hook it up to my external speakers and I can play audio to the speakers just fine and I can hook up my guitar and use garageband just fine.

But for some reason in reaper, when I set my audio device to the tascam, reaper slows down and is laggy, even the scrolling in the preferences window and everything else. I can't play guitar through it at all, all you hear are just shorts bursts of the sound because it's lagging too much.

I loaded an mp3 file into reaper and tried playing it and it was very laggy/jittery and even the clock on reaper was acting the same. but as soon as I set my audio device to the built in output, then reaper works perfectly fine and has no problems.

Any ideas, I'm lost.
#2
I'm not a mac user, but my first instinct is that it might be a performance issue, unfortunately. I'd expect a macbook pro to outmatch a 2-year-old Asus any day of the week, but it sounds to me like your processor can't handle the strain. Either that, or it could be a driver issue. Try disabling a lot of the more cpu-intensive plugins when you plug into the tascam and see if you notice an improvement; if so, it's your processor. If not, triple-check your drivers, disable all other audio programs, and maybe search around Google for some people with a similar issue and see if they found a fix.
#3
Definitely a processor issue. I had the same issue myself, and that's why I'm getting a new computer. (Yes, my laptop was that bad.)

Also, are you using ASIO in Repear? That helps.
#4
I have an i7 (third gen) and 8gb of ram. My asus was an i3 (second gen) with 4 gb ram.

and I'm not running any plugins when I'm in reaper. I just arm a track, and turn on monitoring to at least get a dry signal. While doing this, I've tried looking at Activity Monitor (Mac's task manager) but even though reaper acts really slow, it doesn't show anything out of the ordinary in %CPU and what not.

I might try reinstalling tascam's drivers for it
#6
Quote by crazysam23_Atax
Definitely a processor issue. I had the same issue myself, and that's why I'm getting a new computer. (Yes, my laptop was that bad.)

Also, are you using ASIO in Repear? That helps.


Coming from windows (where I used ASIO) I thought I would need that, but after researching apparently Macs don't need ASIO because they have CoreAudio native or something
#7
I uninstalled the tascam 2.10 driver and then installed the 2.00 driver and now it works perfectly