#1
I'm looking to start doing some simple home recording, so I bought a knock-off ucg102. I originally tried Ableton Live Lite as it came free with the Fender Mustang I owned, but it's as confusing as hell, so I got Reaper instead (the fact that everyone here uses Reaper also had something to do with it. I tried Audacity but it seemed a bit ... rudimentary). I also read that I'd need ASIO4ALL, so that's been installed as well.

Now, my issue is I can get sound in fine using "Microphone USB Audio Codec" as the input device, and it'll play back after it's been recorded fine as well. The track picks it up no worries (the little VU Meter jumps when I play and all that), but there's no sound WHILE I'm playing. The output device is "Speakers (Realtek High Definiti" which I believe is just the computers speakers(?). I tried sending it to "Microphoe USB Audio Codec" which would be the headphone jack on the ucg102(?) but that didn't work either.

Also, I made a drum track in Guitar Pro and imported it into Reaper, and my playing was a tiny bit behind, but I was playing in time when I recorded it? I believe this is a latency issue?